Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Problem with Indel Target Realigner, extra contig added?

JBauerJBauer Member ✭✭

I run into a problem after the pre-processing, it seems that extra contigs where added to my bam file compared to the reference I used, which make the indel realigner step impossible to do. I have checked the headers of my file and the reference is the same but my bam file as a hundreds of additional contigs. Not sure what happen.
The steps to get the bam where:

  • Aligned with bwa mem
  • Transform to bam and sort (Samtools)
  • Dedup (picard)
  • Add read group (picard)
  • Index bam (samtools)
  • Run Realigner target creator
    When I check the header of my bam file it still show the right contigs but when running it complains of difference (additional) compare to my reference. I am currently re-testing the whole pipeline on a single sample but if you have any pointer to what could cause this, maybe a problem with the bam formating?
    I am running GATK 3.3.0-g37228af
    Java 1.7
    I have attached the ouput log from the command.


PS: I attended your workshop in Cambridge!

Issue · Github
by Geraldine_VdAuwera

Issue Number
Last Updated

Best Answer


  • JBauerJBauer Member ✭✭

    Thanks Geraldine.
    It worked afer I re-added the header to the vcf file has your script removed them. Obviously this resulted in the column spacing being mixed up but it is running now!

Sign In or Register to comment.