We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

ABSOLUTE input segmentation file

Hi,

I am writing to seek your help in running ABSOLUTE for tumor-normal pairs for Zebrafish reference genome. We are interested in getting the tumor ploidy.

I have the segmentation file and the mutation file (output from MuTect).After loading the package in R , I follow the steps to run ABSOLUTE (with default options) mentioned at:
http://www.broadinstitute.org/cancer/cga/absolute_run

install.packages("numDeriv”)
library(ABSOLUTE)
RunAbsolute("Sample_BC06_seg.dat",sigma.p="0",max.sigma.h ="0.015", min.ploidy="0.95",max.ploidy="10",primary.disease = "melanoma", platform = 'Illumina_WES', sample.name = "BC06", results.dir = "BC06_output", max.as.seg.count = "1500", max.non.clonal = "0.05" , max.neg.genome = "0", copy_num_type ="allelic", maf.fn="Sample_BC06_Sample_BC12_MuTect_filtered.vcf", min.mut.af = "0", output.fn.base=NULL, verbose=TRUE)
Error: bad restore file magic number (file may be corrupted) -- no data loaded
In addition: Warning message:
file ‘Sample_BC06_seg.dat’ has magic number 'Chrom'
Use of save versions prior to 2 is deprecated

See attached Segmentation file

Could you please let me know if I missed something here.
Appreciate all the help.

Thanks
Sharvari

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi there,

    I've forwarded your question to the developer of ABSOLUTE. We'll try to get you some answers.

  • sgujjasgujja Member

    Hello Geraldine,

    Just checking to see if you heard back from the ABSOLUTE team.

    Could you please let me know.

    Thanks
    Sharvari

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    I'm afraid I haven't heard back from them yet. It can take a few days if they are very busy. For what it's worth, the error message seems to suggest that the input file is not being parsed correctly, so it could be a format issue.

  • sgujjasgujja Member

    Yes, but I am not sure what the issue might be with the input file.It has all the columns mentioned in the manual which is why I need some help on what's amiss.

    Thanks
    Sharvari

  • sgujjasgujja Member

    Hello Geraldine,

    Just wanted to touch base to see if you have any update on this issue?

    Please advice.

    Thanks
    Sharvari

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    I'm afraid I haven't, sorry. I'll ping the developers again -- if that doesn't work I'll barge into their office and demand answers ;)

  • sgujjasgujja Member

    Hello Geraldine,
    Thank you for following up on this. I am really hoping for ABSOLUTE to work to determine tumor ploidy.

    I just need to know if my input segmentation file is valid (It has all the columns mentioned in the manual). And the min mutation allelic rate when MAF file is given.

    I really appreciate all the help.
    Look forward to hearing from you soon.
    Thanks
    Sharvari

  • sgujjasgujja Member

    Hi Geraldine,

    Could you please let me know if you have any update.

    Thanks
    Sharvari

  • sgujjasgujja Member

    Hello,
    Just wondering if you had any luck getting in touch with the ABSOLUTE developers.
    Thanks
    Sharvari

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi @sgujja , I'm afraid they have not been responsive at all. I think at this point you should assume that they will not provide any support for running their software. I find that sad and will ask the group leaders to do something about it, but in the meantime there is nothing more I can do to help you, sorry.

  • sgujjasgujja Member

    That's very sad indeed! We were really hoping for this tool to work and spent quite some time in generating the inputs. Thank you for the update. I really appreciate it.

  • kschweigkschweig californiaMember
    edited September 2015

    I think I have this figured out. The error is because of the use of a load() statement on a file that is not an .RData file (http://stackoverflow.com/questions/12463583/what-could-cause-a-bad-magic-number-error-when-loading-an-r-workspace-and-how). The default input for hapseg are R files (probably produced by their genepattern pipeline). If you are using apt to generate the analysis files from the raw CEL files, then you have to specify an alternate parser

    snp.file.parser=AptSnpFileParser
    clusters.file.parser=BirdseedClustersFileParser

    note in their instructions page they have "cluster.file.parser=BirdseedClustersFileParser" missing the "s"

    In the end, I ran apt this way:

    !/bin/bash

    LIBDIR=/ab_data/Analysis/AffyLib/GenomeWideSNP_6
    HG19DIR=/ab_data/Analysis/AffyLib/hg19

    apt-probeset-genotype \
    -c $LIBDIR/GenomeWideSNP_6.cdf \
    -a birdseed-v2 \
    --set-gender-method cn-probe-chrXY-ratio \
    --chrX-probes $LIBDIR/GenomeWideSNP_6.chrXprobes \
    --chrY-probes $LIBDIR/GenomeWideSNP_6.chrYprobes \
    --read-models-birdseed $LIBDIR/GenomeWideSNP_6.birdseed-v2.models \
    --special-snps $LIBDIR/GenomeWideSNP_6.specialSNPs \
    --annotation-file $HG19DIR/GenomeWideSNP_6.na35.annot.csv \
    --table-output true \
    --output-context true \
    --summaries true \
    --cc-chp-output true \
    --write-models \
    --set-analysis-name GSE36908_snp6 \
    --out-dir ./genotyping \
    --cel-files cellist

    apt-probeset-summarize \
    --cdf-file $LIBDIR/GenomeWideSNP_6.cdf \
    --analysis quant-norm.sketch=0,pm-only,med-polish,expr.genotype=true \
    --set-analysis-name GSE36908_snp6 \
    --out-dir ./genotyping \
    --cel-files cellist

    where cellist is a file having the form:

    cel_files
    ./CEL/GSM911200_CLL001.CEL
    ./CEL/GSM911201_CLL001pn.CEL
    ./CEL/GSM911202_CLL002.CEL
    ./CEL/GSM911203_CLL002pn.CEL

    This produced the following files:
    apt-probeset-genotype.log
    apt-probeset-summarize.log
    cc-chp
    GSE36908_snp6.calls.txt
    GSE36908_snp6.confidences.txt
    GSE36908_snp6.report.txt
    GSE36908_snp6.snp-models.txt
    GSE36908_snp6.summary.txt

    As a test I ran hapseg like this on one tumor normal pair:

    library(HAPSEG)

    RunHapSeg(plate.name="GSM911200", array.name="GSM911200_CLL001", normal=FALSE, seg.fn=NULL, snp.fn="../genotyping/GSE36908_snp6.summary.txt", calls.fn="../genotyping/GSE36908_snp6.calls.txt", clusters.fn="../genotyping/GSE36908_snp6.snp-model
    s.txt", use.normal=TRUE, mn.sample="GSM911201_CLL001pn", genome="hg19", results.dir="./results", platform="SNP_6.0", use.pop="CEPH", impute.gt=FALSE, plot.segfit=TRUE, merge.small=TRUE, merge.close=TRUE, min.seg.size=5, out.p=0.001, seg.merge
    .thresh=1e-10, calibrate.data=TRUE, snp.file.parser=AptSnpFileParser, clusters.file.parser=BirdseedClustersFileParser, adj.atten=FALSE, drop.x=TRUE, verbose=TRUE)

    This seemed to work.

    -karl

  • SheilaSheila Broad InstituteMember, Broadie ✭✭✭✭✭

    @kschweig
    Hi Karl,

    Thank you for posting your findings.

    -Sheila

  • vakulmohantyvakulmohanty Cincinnati OhioMember

    Is there a way this can be fixed to run ABSOLUTE directly on seg files like ones downloaded from TCGA.
    I'm attempting to compute ploidy and absolute copy numbers on these samples using ABSOLUTE.
    Any suggestions will be greatly appreciated.

    Vakul

    Issue · Github
    by Sheila

    Issue Number
    212
    State
    open
    Last Updated
    Assignee
    Array
    Milestone
    Array
  • SheilaSheila Broad InstituteMember, Broadie ✭✭✭✭✭

    @vakulmohanty
    Hi Vakul,

    Unfortunately, we cannot help you much here on this forum. However, it may be a good idea to try posting your question to Biostars or the CGA forum. http://www.broadinstitute.org/cancer/cga/forum/5

    In addition, you may want to contact the TCGA FireBrowse team and suggest these be made available in the new format.

    Good luck!

    -Sheila

Sign In or Register to comment.