ERROR MESSAGE: Code exception

I got this error during local realignment

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.InternalError
at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:838)
at sun.misc.URLClassPath.getResource(URLClassPath.java:199)
at sun.misc.URLClassPath.getResource(URLClassPath.java:251)
at java.lang.ClassLoader.getBootstrapResource(ClassLoader.java:1305)
at java.lang.ClassLoader.getResource(ClassLoader.java:1144)
at java.lang.ClassLoader.getResource(ClassLoader.java:1142)
at java.lang.ClassLoader.getSystemResource(ClassLoader.java:1267)
at java.lang.ClassLoader.getSystemResourceAsStream(ClassLoader.java:1370)
at java.lang.Class.getResourceAsStream(Class.java:2101)
at javax.xml.stream.SecuritySupport$4.run(SecuritySupport.java:92)
at java.security.AccessController.doPrivileged(Native Method)
at javax.xml.stream.SecuritySupport.getResourceAsStream(SecuritySupport.java:87)
at javax.xml.stream.FactoryFinder.findJarServiceProvider(FactoryFinder.java:335)
at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:302)
at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:215)
at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:154)
at org.simpleframework.xml.stream.NodeBuilder.(NodeBuilder.java:48)
at org.simpleframework.xml.core.Persister.write(Persister.java:1000)
at org.simpleframework.xml.core.Persister.write(Persister.java:982)
at org.simpleframework.xml.core.Persister.write(Persister.java:963)
at org.broadinstitute.sting.gatk.phonehome.GATKRunReport.postReportToStream(GATKRunReport.java:377)
at org.broadinstitute.sting.gatk.phonehome.GATKRunReport.postReportToAWSS3(GATKRunReport.java:569)
at org.broadinstitute.sting.gatk.phonehome.GATKRunReport.postReport(GATKRunReport.java:352)
at org.broadinstitute.sting.gatk.CommandLineExecutable.generateGATKRunReport(CommandLineExecutable.java:16
at org.broadinstitute.sting.gatk.CommandLineExecutable.generateGATKRunReport(CommandLineExecutable.java:17
at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(CommandLineExecutable.java:122)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:248)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:155)
at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:107)
Caused by: java.io.FileNotFoundException: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.75.x86_64/jre/lib/resources.jar
at sun.misc.URLClassPath$JarLoader.getJarFile(URLClassPath.java:726)
at sun.misc.URLClassPath$JarLoader.access$600(URLClassPath.java:591)
at sun.misc.URLClassPath$JarLoader$1.run(URLClassPath.java:673)
at sun.misc.URLClassPath$JarLoader$1.run(URLClassPath.java:666)
at java.security.AccessController.doPrivileged(Native Method)
at sun.misc.URLClassPath$JarLoader.ensureOpen(URLClassPath.java:665)
at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:836)
... 28 more

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 3.1-1-g07a4bf8):
ERROR
ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
ERROR If not, please post the error message, with stack trace, to the GATK forum.
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: Code exception (see stack trace for error itself)
ERROR ------------------------------------------------------------------------------------------

Would you tell me how to correct this error :(

Best Answer

Answers

  • leefallleefall SeoulMember

    @Geraldine_VdAuwera

    Thanks for your answering :)

    Unfortunately, I use java version "1.7.0_79".

    This below is whole printed message when I type run "java -version"

    java version "1.7.0_79"
    OpenJDK Runtime Environment (rhel-2.5.5.1.el6_6-x86_64 u79-b14)
    OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

    Is it still problem with java version??

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Ah, currently we do not support OpenJDK, that may be your problem. You'll need to get the mainstream version of the JDK from Oracle.

  • lyndaeldolyndaeldo uaeMember

    Most of these bugs are probably historical; i.e. fixed in earlier versions of Java. (But then you didn't clearly specify which version you were talking about. How recent? Usual for who?). In addition to the reported bugs, there probably lots of ways that you could cause these errors to occur if you were prepared to interfere with the Java installation (e.g. tweak the "rt.jar" file) or mess around in native code. More about....Java Exceptions

    Lynda

Sign In or Register to comment.