Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office on November 11th and 13th 2019, due to the U.S. holiday(Veteran's day) and due to a team event(Nov 13th). We will return to monitoring the GATK forum on November 12th and 14th respectively. Thank you for your patience.

Base recalibrator error

swongswong Phoenix, AZMember

Hello, I am trying to run baserecalibrator on a bam file after it has completed the Split'N'Trim + ReassignMappingQuality module as documented in the RNASeq Best Practices but am getting an error.

java -jar /home/swong/bin/GenomeAnalysisTK-3.3-0/GenomeAnalysisTK.jar –T BaseRecalibrator –R /home/swong/reference/hs37d5.fa -I TNBC_0019_1_BE_Whole_T3_O2KON_J00264.proj.Aligned.out.PICARD.sorted.dedup.ADDRG.SPLIT.bam –knownSites /home/swong/gatk_bundle_2.5/b37/dbsnp_137.b37.vcf –knownSites /home/swong/gatk_bundle_2.5/b37/Mills_and_1000G_gold_standard.indels.b37.vcf -o J00264_recal_data.table

ERROR MESSAGE: Invalid argument value '???T' at position 0.
ERROR Invalid argument value 'BaseRecalibrator' at position 1.
ERROR Invalid argument value '???R' at position 2.
ERROR Invalid argument value '/home/swong/reference/hs37d5.fa' at position 3.
ERROR Invalid argument value '???knownSites' at position 6.
ERROR Invalid argument value '/home/swong/gatk_bundle_2.5/b37/dbsnp_137.b37.vcf' at position 7.
ERROR Invalid argument value '???knownSites' at position 8.
ERROR Invalid argument value '/home/swong/gatk_bundle_2.5/b37/Mills_and_1000G_gold_standard.indels.b37.vcf' at position 9.

Not sure what I am doing wrong; I am very new to this and am trying to learn but following the tutorials exactly. Thank you very much!

Best Answers

Answers

  • swongswong Phoenix, AZMember

    Thank you so much pdexheimer!!! It was such a simple mistake. I have been pasting all my commands in Word to keep track of what I did and never thought that will cause any issues.

  • swongswong Phoenix, AZMember

    @Geraldine_VdAuwera, thank you. I will do that from now on.

Sign In or Register to comment.