Running HaplotypeCaller in GENOTYPE_GIVEN_ALLELES mode with --emitRefConfidence GVCF

gerhtbgerhtb South AfricaMember

Hi Sheila and Geraldine

When I run HaplotypeCaller (v3.3-0-g37228af) in GENOTYPE_GIVEN_ALLELES mode with --emitRefConfidence GVCF I get the error:

Invalid command line: Argument ERC/gt_mode has a bad value: you cannot request reference confidence output and GENOTYPE_GIVEN_ALLELES at the same time

It is however strange that GENOTYPE_GIVEN_ALLELES is mentioned in the --max_alternate_alleles section of the GenotypeGVCFs documentation.

Maybe I'm missing something?

Thanks,
Gerrit

Best Answer

Answers

  • tommycarstensentommycarstensen United KingdomMember ✭✭✭

    It would be great, if GenotypeGVCFs could support GENOTYPE_GIVEN_ALLELES if it doesn't already.

  • gerhtbgerhtb South AfricaMember

    Thanks Sheila,

    So --genotyping_mode should be an option when running GenotypeGVCFs. This is not documented though.

    Gerrit

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    This may be an oversight. The workflow that GenotypeGVCFs is part of is meant for a rather different use case, so the GGA capability of the core genotyping engine (that is common to all the callers) may not have been hooked up in this tool. There is no reason I can think of why it shouldn't work, though. I'll see if we can make this a feature request for a future version.

  • eablckeablck iowaMember

    Hi Geraldine, We would also like to use -gt_mode GENOTYPE_GIVEN_ALLELES with GenotypeGVCF. I was wondering if a feature was opened and there are plans to support it?

    Thanks so much,

    Ann

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Not at this time -- there is some discussion about what to do with GGA mode but nothing concrete has been planned. It's unlikely that we're going to be making any substantial changes to this part of the toolchain in the near future until we have the full pipeline ported to GATK4, plus a few performance-oriented features sorted out, which could take a few more months.

  • aklakl Member

    Why did Sheila says "GenotypeGVCFs supports GENOTYPE_GIVEN_ALLELES". When I run my command

    java -jar "E:\GenomeAnalysisTK.jar" -T GenotypeGVCFs -R E:\genome.fa --variant ML4delEX1_EX7-31031_S2.bam.2snv.g.vcf -o ML4delEX1_EX7-31031_S2.bam.2snv.g.vcf.gtga.allSites.vcf --includeNonVariantSites -L E:\2snv.vcf.gz --genotyping_mode GENOTYPE_GIVEN_ALLELES --alleles E:\2snv.vcf.gz

    I get the error "Argument with name 'genotyping_mode' isn't defined?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin
    edited December 2016

    @akl
    Hi,

    I think there was some confusion on my end last year. I thought GGA mode was supported, but in fact, it is not supported in GVCF workflow. I am sorry for the confusion. Have a look at this thread for some workarounds.

    -Sheila

    Edit: @gerhtb @tommycarstensen
    Hi,

    Did you two find a workaround for GGA mode in the GVCF workflow you can share?

    Thanks,
    Sheila

Sign In or Register to comment.