Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

'no @SQ lines in the header'

Hi all..

I'm stuck at the path where I'm about to call mitochondrial region (ChrM) from the whole genome sequencing data.

I have gone through the fastq, alignment and now I'm going deeper; calling ChrM out (because I'm specifically want to use mitochondrial region only for my study).

What I did was;

1) I have sorted .bam file, the command was like:

samtools sort unsorted_in.bam sorted_out

2) Then I converted the sorted .bam file into .sam. The command was:

samtools view -h file.bam > file.sam

3) After that, I have indexed sorted.bam file and the command was:

samtools index sorted.bam

Everything seems okay until I run the command to call ChrM region. The command for calling ChrM that I have used was this one:

samtools view -h sorted.bam | awk '$3== "chrM" || /[email protected]/' | samtools view -Sb -> chrM.bam.sorted.bam

So, I typed this in the terminal and it appeared:

[email protected]:/srv/disk01/Tools/samtools-0.1.19$ samtools view -h /srv/disk01/Postgraduates/OrangAsli/KS12R/Alignments/KS12R_sorted.bam.bam | awk '$3=="chrM" || /[email protected]/' | samtools view -Sb -> /srv/disk01/Postgraduates/OrangAsli/KS12R/ChrM/KS12R_chrM.bam.sorted.bam
[samopen] no @SQ lines in the header.
[sam_read1] missing header? Abort!

I have tried more than twice but it's still the same. What does it mean with 'no @SQ lines in the header?'

I hope you guys can help me. Thank you in advance and glad to hear from you guys soon.

Thanks again,
Lynn.

Best Answer

Answers

  • AzlinAzlin Member

    Hi Geraldine,

    Uh-oh. My bad. Thank you for your suggestion :smile:

Sign In or Register to comment.