If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Problem with BaseRecalibrator

I am trying to use BaseRecalibrator and I keep getting the error below. I am using GATK v3.3-0 and java 1.8.0_25. Here is the command line:

java -jar GenomeAnalysisTK-3.3-0/GenomeAnalysisTK.jar -R genome.fa -knownSites dbsnp_138.hg19.vcf -I SP033.marked.realigned.fixed.bam -T BaseRecalibrator -o SP033.recal_data.csv -cov ReadGroupCovariate -cov QualityScoreCovariate -cov CycleCovariate -cov ContextCovariate

I also tried to run it without specifying the -cov parameters, but I get the same error. What can I do to fix this?

NFO 13:29:07,885 HelpFormatter - --------------------------------------------------------------------------------
INFO 13:29:07,887 HelpFormatter - The Genome Analysis Toolkit (GATK) v3.3-0-g37228af, Compiled 2014/10/24 01:07:22
INFO 13:29:07,887 HelpFormatter - Copyright (c) 2010 The Broad Institute
INFO 13:29:07,887 HelpFormatter - For support and documentation go to
INFO 13:29:07,891 HelpFormatter - Program Args: -R genome.fa -knownSites dbsnp_138.hg19.vcf -I SP033.marked.realigned.fixed.bam -T BaseRecalibrator -o SP033.recal_data.csv -cov ReadGroupCovariate -cov QualityScoreCovariate -cov CycleCovariate -cov ContextCovariate
INFO 13:29:07,903 HelpFormatter - Executing as [email protected] on Mac OS X 10.10.1 x86_64; Java HotSpot(TM) 64-Bit Server VM 1.8.0_25-b17.
INFO 13:29:07,903 HelpFormatter - Date/Time: 2015/01/07 13:29:07
INFO 13:29:07,903 HelpFormatter - --------------------------------------------------------------------------------
INFO 13:29:07,904 HelpFormatter - --------------------------------------------------------------------------------
INFO 13:29:08,246 GenomeAnalysisEngine - Strictness is SILENT
INFO 13:29:08,312 GenomeAnalysisEngine - Downsampling Settings: No downsampling
INFO 13:29:08,318 SAMDataSource$SAMReaders - Initializing SAMRecords in serial
WARNING: BAM index file /Users/Alessandro/Research/Work/multiple myeloma/MSSM-WES/SP033.marked.realigned.fixed.bai is older than BAM /Users/Alessandro/Research/Work/multiple myeloma/MSSM-WES/SP033.marked.realigned.fixed.bam
INFO 13:29:08,348 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.03
INFO 13:29:08,516 GenomeAnalysisEngine - Preparing for traversal over 1 BAM files
INFO 13:29:08,519 GenomeAnalysisEngine - Done preparing for traversal
INFO 13:29:08,520 ProgressMeter - | processed | time | per 1M | | total | remaining
INFO 13:29:08,520 ProgressMeter - Location | reads | elapsed | reads | completed | runtime | runtime
INFO 13:29:08,611 BaseRecalibrator - The covariates being used here:
INFO 13:29:08,611 BaseRecalibrator - ReadGroupCovariate
INFO 13:29:08,612 BaseRecalibrator - QualityScoreCovariate
INFO 13:29:08,612 BaseRecalibrator - ContextCovariate
INFO 13:29:08,612 ContextCovariate - Context sizes: base substitution model 2, indel substitution model 3
INFO 13:29:08,612 BaseRecalibrator - CycleCovariate
INFO 13:29:08,614 ReadShardBalancer$1 - Loading BAM index data
INFO 13:29:08,615 ReadShardBalancer$1 - Done loading BAM index data
INFO 13:29:09,991 GATKRunReport - Uploaded run statistics report to AWS S3

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.ArrayIndexOutOfBoundsException: -7
at org.broadinstitute.gatk.utils.baq.BAQ.calcEpsilon(
at org.broadinstitute.gatk.utils.baq.BAQ.hmm_glocal(
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(
at org.broadinstitute.gatk.utils.baq.BAQ.calcBAQFromHMM(
at org.broadinstitute.gatk.utils.baq.BAQ.baqRead(
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsMap.apply(
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano$TraverseReadsMap.apply(
at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler.executeSingleThreaded(
at org.broadinstitute.gatk.utils.nanoScheduler.NanoScheduler.execute(
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano.traverse(
at org.broadinstitute.gatk.engine.traversals.TraverseReadsNano.traverse(
at org.broadinstitute.gatk.engine.executive.LinearMicroScheduler.execute(
at org.broadinstitute.gatk.engine.GenomeAnalysisEngine.execute(
at org.broadinstitute.gatk.engine.CommandLineExecutable.execute(
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(
at org.broadinstitute.gatk.utils.commandline.CommandLineProgram.start(
at org.broadinstitute.gatk.engine.CommandLineGATK.main(

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 3.3-0-g37228af):
ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
ERROR If not, please post the error message, with stack trace, to the GATK forum.
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions
ERROR ------------------------------------------------------------------------------------------


Sign In or Register to comment.