IndelRealigner losing some reads

DaliaDalia Member
edited November 2014 in Ask the GATK team

Hi,

Recently I experienced a slightly annoying problem with IndelRealigner loosing some reads. It is usually just few reads missing from the output, but when I compare the output and input and extract the reads taht are missing after the IndelRealigner job, I cannot see what is wrong with them. An example of one such read is below:

M01823:187:000000000-AB050:1:1109:16397:19623 69 8 64405501 0 * = 64405501 0 TTTGCTTTCAAAAATACCTGTGCAGGTGGAGGTGTGCGTCTGCGTCTAACGGTGTGCGGTGCGAATTTCGACGATCGTTGCATTAACTTGCGAAACCCCTCATCTCGTATGCCGTCTTCTGCTTGAAAAAAAAAAAAAAAAAAAAATAAAACAAACAAAACGAACTACTACAGACAACGACAAAAACCAAAAAACAACATATAAACAAATAAACGAGCAACACAACACAAATAAAAGAGCAAGCACTACAC CCCCCGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGFGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGG885+3355<,8,,=,,,,,,3,,=4::?,,7,,7,*2+14<********/*/2***1/*0+++2++2/+++++*2*12*2*****2*;*/++2+++1:68***20++++* RG:Z:140919_M01823_0188_000000000-AB050_AACCCCTC-TGTTCTCT_L001 AS:i:0 XS:i:0

It's pair has been kept, but this read was removed.

It is a bit of nuisance, as in our workflow we check the number of reads in the files after various steps for sanity, so varying number of reads introduces problems. I would be grateful if you could adviice why some reads get ommitted by IndelRealigner so I could modufy our workflow accordingly. Or could it be a bug?

Thank you,
Dalia

Post edited by Dalia on
Tagged:

Best Answer

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Dalia‌

    Hi Dalia,

    Can you please post your exact command line and which version of GATK you are using?

    Thanks,
    Sheila

  • I was using GATK-3.2-2 and the command arguments were:

    -T IndelRealigner -R /tmp/pbs.8265961.cx1b/reference.fa -I /tmp/pbs.8265961.cx1b/chunk.bam -targetIntervals IGFP001926.chunk_1.RTC.intervals -known 1000G_phase1.indels.b37.vcf -known Mills_and_1000G_gold_standard.indels.b37.vcf -o IGFP001926.chunk_1.realigned.bam -L /tmp/pbs.8265961.cx1b/fragment.intervals -L unmapped

    I have now updated to GATK 3.3 and will let you know if the issue still persists.

  • @Sheila‌
    Hi, I have tested using v3.3-0-g37228af and still have the same problem.

  • @Sheila‌

    Thanks, so far i only observed this when one of the pair was mapped, and the unmapped read was lost. I have modified our workflow to tolerate this, but if I see the loss of mapped reads, I will let you know.

    Thanks,
    Dalia

Sign In or Register to comment.