DepthOfCoverage: ERROR MESSAGE: Error parsing line at byte position

Hi all,

I am using depthofCoverage tool as shown below:

  java -Xmx2g -jar GenomeAnalysisTK.jar -T DepthOfCoverage -R  ucsc_hg19.fa -geneList:REFSEQ refGene.bed -L exons.bed -ct 1 -ct 5 -ct 10 -ct 20 -ct 50 -I WT_recalibrated.bam -o cov 

Original exons.bed file looks like:

 chr1    6526151 6527632 PLEKHG5_1       0       +
 chr1    6527884 6528646 PLEKHG5_2       0       +
 chr1    6529101 6529301 PLEKHG5_3       0       +
 chr1    6529394 6529510 PLEKHG5_4       0       +
 chr1    6529603 6529736 PLEKHG5_5       0       +
 chr1    6530295 6530415 PLEKHG5_6       0       +
 chr1    6530565 6530703 PLEKHG5_7       0       +
 chr1    6530794 6530944 PLEKHG5_8       0       +
 chr1    6531049 6531697 PLEKHG5_9       0       +

Then, refGene.bed file is prepared based on the awk solution provided at the thread 'http://gatkforums.broadinstitute.org/discussion/3229/exon-output-depth-of-coverage'

refGene.bed

1       PLEKHG5_exon_1       chr1    +       6526151 6527632 6526151 6527632 1       6526151 6527632 0       PLEKHG5 exon_1  cmpl    cmpl    0
2       PLEKHG5_exon_2       chr1    +       6527884 6528646 6527884 6528646 1       6527884 6528646 0       PLEKHG5 exon_2  cmpl    cmpl    0
3       PLEKHG5_exon_3       chr1    +       6529101 6529301 6529101 6529301 1       6529101 6529301 0       PLEKHG5 exon_3  cmpl    cmpl    0
4       PLEKHG5_exon_4       chr1    +       6529394 6529510 6529394 6529510 1       6529394 6529510 0       PLEKHG5 exon_4  cmpl    cmpl    0
5       PLEKHG5_exon_5       chr1    +       6529603 6529736 6529603 6529736 1       6529603 6529736 0       PLEKHG5 exon_5  cmpl    cmpl    0

However, the above command returns the error:

 ##### ERROR MESSAGE: Error parsing line at byte position: [email protected], for input source:refGene.bed

Could someone help to fix this. This is not basically a refGene file. This is prepared from a custom exon.bed file which doesn't have refGene notations using the awk solution in the above thread.

Tagged:

Best Answer

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hmm, sounds like a file formatting or integrity issue. I would try to narrow down the location of the error by trying to pass in a few lines first (to check that it's not failing on the very first line) then try bisecting the file progressively until you find which line is causing the problem.

  • meharmehar Member ✭✭

    Hi Geraldine,

    I passed only one line and it failed with the same error. Couldn't figure out the root cause for the issue. The gene list is not as per refseq nomenclature, it is only in the format specified in the above post. I hope this is not an issue. Could you think of any other possible sources of error?

Sign In or Register to comment.