Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

FindCoveredIntervals not recognizing --activeRegionIn option

andrewoandrewo Member
edited October 2014 in Ask the GATK team

Hi,

I'm trying to run FindCoveredIntervals one chromosome at a time, so I'm using the --activeRegionIn option. However it doesn't seem to be reconized, no matter how I format it. For example, my basic command is like this:

java -Xmx3G -jar GenomeAnalysisTK.jar \
-T FindCoveredIntervals \
-R ucsc.hg19.fasta \
-I bwa.bam \
-o bwa.20xCov.chr22.list \
--minBaseQuality 17 \
--minMappingQuality 20 \
--coverage_threshold 20 \
--activeRegionIn chr22.list

I tried this two ways: 1) chr22.list file containing a single line "chr22" and 2) chr22.list file containing the line "chr22:1-51304566". In both cases, the interval walker starts with chr1:

INFO 13:15:48,925 ProgressMeter - [INITIALIZATION COMPLETE; STARTING PROCESSING]
INFO 13:15:48,925 ProgressMeter - | processed | time | per 1M | | total | remaining
INFO 13:15:48,926 ProgressMeter - Location | active regions | elapsed | active regions | completed | runtime | runtime
INFO 13:16:18,936 ProgressMeter - chr1:823974 16571.0 30.0 s 30.2 m 0.0% 31.1 h 31.1 h

I've tried "--activeRegionIn chr22" and "-AR chr22" as well, which both start processing at chr1.

Am I doing something wrong? Any ideas on how to get this to process data for an individual chromosome without splitting up the BAM file?

Thanks,

Andrew

EDIT: I'm using GATK 3.2

Answers

  • andrewoandrewo Member
    edited October 2014

    After some more testing, I determined that the parameter I need is -L from the GATK basic command-line options instead of --activeRegionIn. Using -L chr22 works just fine.

Sign In or Register to comment.