Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

What is the cause of this error: ERROR MESSAGE: Invalid argument value '/mnt/galaxy/tools/gatk2/bin/

I have installed GATK2 into a galaxy cloud instance to use the Unified Genotyper for our sequencing course. However, when I run the tool I get the following error message:

Dataset 41: Unified Genotyper on data 8 and data 13 (VCF)

Tool execution generated the following error message:

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.2-2-gec30cee):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: Invalid argument value '/mnt/galaxy/tools/gatk2/bin/' at position 8.
ERROR ------------------------------------------------------------------------------------------

I have reviewed my configuration files and cannot locate where the issue lies. I am also posting this with the Galavy-Dev team to see if they have any ideas. Unfortunately I need to get this resolved ASAP since I need to complete my testing by tomorrow.

Best Answer

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @iwitham‌

    Hi,

    Can you post your exact command line?

    -Sheila

  • iwithamiwitham Member

    Here is the command:

    python /mnt/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/iuc/gatk2/84584664264c/gatk2/gatk2_wrapper.py --stdout "/mnt/galaxy/files/000/dataset_341.dat" -d "-I" "/mnt/galaxy/files/000/dataset_226.dat" "bam" "gatk_input_0" -d "" "/mnt/galaxy/files/_metadata_files/000/metadata_13.dat" "bam_index" "gatk_input_0" -p ' java -jar "$GATK2_PATH/GenomeAnalysisTK.jar" -T "UnifiedGenotyper" --num_threads ${GALAXY_SLOTS:-4} --out "/mnt/galaxy/files/000/dataset_339.dat" --metrics_file "/mnt/galaxy/files/000/dataset_340.dat" $GATK2_SITE_OPTIONS --num_cpu_threads_per_data_thread 1 --genotype_likelihoods_model "BOTH" --standard_min_confidence_threshold_for_calling "30.0" --standard_min_confidence_threshold_for_emitting "30.0" ' -d "-R" "/mnt/galaxy/files/000/dataset_220.dat" "fasta" "gatk_input"

  • phermyphermy South AfricaMember

    Hi everyone,
    Can anyone please help me to solve the error message. after running this command {java -jar GenomeAnalysisTK.jar -T RealignerTargetCreator -R /home/bioifworkstation1/Desktop/ GCA_000283155.1_CerSimSim1.0_genomic.fna.fai -I dedup_reads.bam -o realignment_targets.list }

    ERROR MESSAGE: Invalid argument value 'GCA_000283155.1_CerSimSim1.0_genomic.fna.fai' at position 4.

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @phermy
    Hi,

    You need to input the reference file to -R, not the reference index file.

    -Sheila

Sign In or Register to comment.