Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office for a Broad Institute event from Dec 10th to Dec 11th 2019. We will be back to monitor the GATK forum on Dec 12th 2019. In the meantime we encourage you to help out other community members with their queries.
Thank you for your patience!

Bug with read clipper and fix_misencoded_quality_scores option

kohrnbkohrnb Portland State UniversityMember

I was softclipping some 84-bp-long single end reads using the following command:

java -Xmx2g -jar /GATK_Path/GenomeAnalysisTK.jar -T ClipReads -I imput_file.bam -o output_file.bam -R $ALIGNREF --cyclesToTrim "1-4,80-84" --clipRepresentation SOFTCLIP_BASES --fix_misencoded_quality_scores

There was no error while running, but when I looked at the file afterwards, every read had a cigar string of 84S. I'm fairly sure this is a bug. I was aligned to the human mitochondrial genome.

I am using GATK v2.3-9-ge5ebf34 on Mac OS 10.75

Best Answer

Answers

Sign In or Register to comment.