UnifiedGenotyper gets lock error

We've used GATK(v2.1-8) in a SGE environment for more than 1 years now. Without any changing in environment, we have had a few cases of UnifiedGenotyper getting hung up while trying to read our previously created .fai and .dict reference files. FSLockWithShared - WARNING: Unable to lock file xxx/ucsc.hg19.dict; ReferenceDataSource - Unable to create a lock on dictionary file.
Then GATK was updated to 2.7-4 and 3.1-1. There was still an error. "ERROR MESSAGE: Timeout of 30000 milliseconds was reached while trying to acquire a lock on file xxx/dbsnp_135.hg19.vcf.idx. Since the GATK uses non-blocking lock acquisition calls that are not supposed to wait, this implies a problem with the file locking support in your operating system."
Besides, there is no problem reported when we run the UnifiedGenotyper step on data store node. This problem happens if we run the UnifiedGenotyper step on compute nodes. We used NFS for shared data between nodes. Is it the way, one is access the data directly and the other one is by NFS shared, leading this problem? If so, how can I fix this problem?
Hoping someone can answer this problem as soon as possible. Thank you!

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi there,

    It's very likely that this is due to your shared file system. If the underlying data is shared between nodes, then different nodes may be trying to access the same file at the same time, which GATK does not support. You'll need to work with you IT support department to figure out how to modify your setup. We cannot advise you on this topic, sorry.

  • YangyangLiuYangyangLiu BNUMember

    this problem can be handled by the parameter "--disable_auto_index_creation_and_locking_when_reading_rods".
    Thanks

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Thanks for reporting back with your solution, I'm sure it will be helpful for other users.

Sign In or Register to comment.