Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

don't understand multi sample snp calling format

I'm a little confused as to the format for multi sample snp calling suing Unified Genotyper. The example says:
-I sample1.bam [-I sample2.bam ...] \ but the presence of the dots is confusing.

Is the right format as in example a) or b) ?
a) -I sample1.bam [-I sample2.bam] [-I sample3.bam] [-I sample4.bam]
b) -I sample1.bam [-I sample2.bam sample3.bam sample4.bam]
I tried both ways and got error both times actually - "invalid argument "[-I"



Best Answer


  • Thanks very much, much appreciate your response. If the original page could be edited to have the example like you have written here, I'm sure it would save much time and effort for a lot of people !

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Ok, we'll try to clarify this in the docs.

  • kritikoolkritikool Member
    edited February 2014

    I have a follow up question regarding this. Is the output by default a multi-sample VCF file , Or do I have to give as many "-o" output files as there are "-I" bam files.
    How do I convert this output to a multi-sample VCF file that I can use for association testing ?

    I tried multi-sample SNP calling with the following parameters and only got one sample in my VCF output:
    java -Xmx2g -jar /software/GenomeAnalysisTK-2.7-4-g6f46d11/GenomeAnalysisTK.jar \
    -R /gatk.ref/ucsc.hg19.fasta -T UnifiedGenotyper \
    -I sample1.bam -I sample2.bam -I sampl3.bam.....-I sample68.bam
    -o /multisample.vcf \
    -glm BOTH -nt 16 -U ALLOW_N_CIGAR_READS >>System.out 2>>System.err

    Post edited by kritikool on
  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    If you call multiple samples, you will get a single VCF with all the results. There is in fact no way to get a separate VCF for each sample.

    What you're seeing may be due to incorrect read group information; you should check the read group info in the headers.

  • I give the same read group string to all samples before I run GATK. When I run single sample GATK on each sample, I have no trouble. But when running multi-sample SNP calling, I find that it just stops after chromosome 7, at which time the VCF file created so far is 50GB, but has only one sample info in it, and the vcf.idx is empty.
    Do you think its a memory issue that is causing the job to crash? Any recommendations ?

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    I give the same read group string to all samples before I run GATK.

    If you give the same read group string, the GATK will think all the data belongs to one sample, and so it makes sense that you only see one sample reported in the VCF. Or am I misunderstanding something?

    It does sound like your jobs are not running to completion due to some memory error. Try increasing memory (use the java -Xmx argument) and see what happens.

Sign In or Register to comment.