MuTect Build Problem

kcibulkcibul Cambridge, MAMember, Broadie, Dev ✭✭✭
This discussion was created from comments split from: MuTect source now available in GitHub!.

Comments

  • andreandre Member

    Hi, I try to follow the build intructions in the MuTect github Readme. It seems to build fine but the packaging does not work (see log attached). When I do a "dist" instead of "package" ant runs through but the only classes related to MuTect in the jar seem to be the queue extensions. Strange.. I wonder if I am doing something wrong?

  • kcibulkcibul Cambridge, MAMember, Broadie, Dev ✭✭✭

    Hi -- I'm not sure what the trouble is that you're having. I just took the instructions from the GitHub Readme and ran them on a clean machine and everything was ok.

    I noticed in your build output it says:

     [echo] Include External?  : no
    

    Which means either you didn't run with the specified command (ant -Dexternal.dir=pwd/../mutect-src -Dexecutable=mutect package)
    or that the mutect-src isn't in the right place relative to the gatk dir. the external.dir above should point to the directory ABOVE the mutect directory. So if you run "ls -l pwd/../mutect-src" you will see:

    bm5fb-3a0:~/andre/gatk-protected [master*] $ ls -l pwd/../mutect-src
    total 0
    drwxr-xr-x 14 kcibul CHARLES\Domain Users 476 Oct 25 21:14 mutect

    Hope this helps

  • andreandre Member

    Thanks for the help. Actually it was an issue with the directory structure. So just for reference, the correct one ist:

    top_level /mutect-src /mutect /gatk-protected

    I probably got confused by the order in which the two repositories are cloned. Anyway, thanks again.

Sign In or Register to comment.