Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Reduce Reads error

rcholicrcholic DenverMember

I recently upgraded from GATK 2.5 to the latest 2.74 stable release, but the Reduce Reads throws the following error when I try to run it with a Bam file that was produced by "PrintReads" (3 samples merged in one Bam file).

MESSAGE: Bad input: Reduce Reads is not meant to be run for more than 1 sample at a time except for the specific case of tumor/normal >pairs in cancer analysis

java -Xmx6g -Djava.awt.headless=true -jar $CLASSPATH/GenomeAnalysisTK.jar \ -T ReduceReads \ -R ../GATK_ref/hg19.fasta \ -I ../GATK/BQSR/all3Samples2.recal.bam \ -o ../GATK/BQSR/all3Samples.recal.compressed.bam

It used to work with the old version of GATK, but it does not work now. Where could it be wrong?

Tagged:

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi @rcholic,

    The error message tells you why it is not working. The fact that it worked before is because we had not yet built in safety measures to prevent people from doing what you are trying to do.

  • jpittjpitt Member

    Hi @Geraldine_VdAuwera

    I was wondering if you could confirm where the ReduceReads walker looks to determine if a bam is composed of 2 or more disparate samples. I presume it looks at the SM field for each of the read groups?

    I've pushed quite a few bams through our analysis workflow and there are a couple hundred that fail due to the above error. All of the reads are in from the same individual, but it appears the sequencing center that generated the data was not consistent with their SM fields in the read groups (some are full sample names and some are abbreviated). Assuming a user is certain that all reads are from the same individual/sample, would a simple solution be to specify the -cancer-mode flag (rather than re-header)?

    Thanks for your help.

  • pdexheimerpdexheimer Member ✭✭✭✭

    Yes, all the GATK tools that operate on the sample level use the SM field. I have no idea if the cancer-mode flag will do what you want, but you absolutely need to fix your bams. Even if you can hack through this step, you'll get more problems in variant calling, and will face an absolute nightmare in the future if you ever come back to this data and "a couple hundred" bams are wrong. It will be well worth your time now to fix the bams and have everything just work. I would also keep a record of exactly what I changed in which files, just in case you ever need to troubleshoot

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi @jpitt, you should definitely fix things so that the read groups, sample info etc are all correct and consistent -- preferably from the start of your pipeline. Using the cancer mode flag is not the right way to deal with this.

Sign In or Register to comment.