The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

DepthOfCoverage multi-threading

Does the walker DepthOfCoverage support multi-threading?

According to the documentation:
http://www.broadinstitute.org/gatk/gatkdocs/org_broadinstitute_sting_gatk_walkers_coverage_DepthOfCoverage.html
"This tool can be run in multi-threaded mode using this option. TreeReducible (-nt)"

When I try with GATK2.5 I get this error message:
"Invalid command line: Argument nt has a bad value: The analysis DepthOfCoverage aggregates results by interval. Due to a current limitation of the GATK, analyses of this type do not currently support parallel execution. Please run your analysis without the -nt option."

Would it work, if I upgraded to 2.7? You upgrade GATK more frequently than I change my under wear, so it is difficult to keep up :) Thanks!

Tagged:

Best Answer

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    Accepted Answer

    Hi Tommy,

    If you don't mind I'll refrain from commenting on your personal hygiene and sartorial habits :)

    But as regards to the issue you're running into: it's not really a version problem. What's happening here is that by default the DoC is set to generate stats averaged over intervals, which is not compatible with multithreading mode. If you pass the --omitIntervalStatistics / -omitIntervals flag this will be disabled and multithreading ability will be restored. We'll look at documenting and/or putting in a workaround to avoid this situation in the future.

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie
    Accepted Answer

    Hi Tommy,

    If you don't mind I'll refrain from commenting on your personal hygiene and sartorial habits :)

    But as regards to the issue you're running into: it's not really a version problem. What's happening here is that by default the DoC is set to generate stats averaged over intervals, which is not compatible with multithreading mode. If you pass the --omitIntervalStatistics / -omitIntervals flag this will be disabled and multithreading ability will be restored. We'll look at documenting and/or putting in a workaround to avoid this situation in the future.

  • tommycarstensentommycarstensen United KingdomMember

    Thank you! I actually prefer getting an error message instead of occupying multiple processors for a single core job.

Sign In or Register to comment.