The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!

You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?

1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?

Then follow instructions in Article#1894.

Formatting tip!

Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

Getting very less entries in vcf file??

Dear Developers,

I Run Unified genotyper for identify the indels and deletion.
I used Realigner target creater got forIndelRealigner.intervals. used this output for Indel Realigner and get the output bam file which i gave as input toUnified Genotyper.
I got result as


gi|262359905|ref|NG_005905.2| 48155 . G A 387.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=-0.466;DP=47;Dels=0.00;FS=2.721;HaplotypeScore=0.0000;MLEAC=1;MLEAF=0.500;MQ=29.31;MQ0=0;MQRankSum=-4.812;QD=8.25;ReadPosRankSum=0.535 GT:AD:DP:GQ:PL 0/1:25,22:45:99:416,0,676

But if i run without these steps (Realigner target creater, Indel Realigner) i am getting the same output.
Also i used the same dataset and run it in samtools and got more SNP.

I am looking for a deletion in the dataset.
I would like to get the result from GATK Could you please suggest on the same.


Best Answer


  • Hello Geraldine,

    Thank you for the detailed reply.
    Actually in the analysis we tried with a software(not samtools) for variant calling and compared the results with GATK here we dint get the deletion we observed.
    I tried Haplotypecaller earlier i got few entries more but the deletion which i expect i dint get it..


  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    I see -- you should definitely try the genotype given alleles mode, then. That will at least give you some metrics on what the caller thinks of the deletion you observe.

  • Hello Geraldine,

    Cold you please tell me how to use the option GENOTYPE_GIVEN_ALLELES ??
    Because it shows error wehn i use UnifiedGenotyper and haplotypecaller..


  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Can you tell me what command line you tried and what error you got?

  • java -jar galaxy/apps/GenomeAnalysisTK-2.5-2-gf57256b/GenomeAnalysisTK.jar -R brca.fasta -T UnifiedGenotyper -I BRCA_S21_picard.bam --GENOTYPE_GIVEN_ALLELES

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Oh, I see. You need to provide a VCF file containing the alleles you are looking for, with the --alleles argument as described here. You can also provide the same VCF to the -L argument if you want to restrict your analysis to just those sites, but that is optional.

Sign In or Register to comment.