Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

BaseCounts with HC

Hi guys!

I used (2.5-2-gf57256b):

java -Xmx32g -jar GenomeAnalysisTK.jar -T HaplotypeCaller -R ../genome.fa 
--dbsnp chrY_ref.vcf  
-I  chrY.bam 
-o chrY.raw.vcf 
-A BaseCounts -A MappingQualityRankSumTest -A ReadPosRankSumTest -A QualByDepth
-A HomopolymerRun -A FisherStrand 
-l INFO 

But I never got the BaseCounts for the SNPs

I tried to add them with VariantAnnotator

 
java -Xmx32g -jar GenomeAnalysisTK.jar -T VariantAnnotator  -R ../genome.fa 
--variant  chrY.raw.vcf 
-A BaseCounts 
-o chrY_ann.vcf
-l INFO

But I get the same file.. Any ideas?

Thanks!

/Marcela

Best Answer

Answers

  • MarcelaDMarcelaD Member

    BTW,

    When passing --dbsnp to the HC, the SNPs are not annotated, however when passing it to VariantAnnotator the SNPs are annotated, but still with no BaseCalls..

    /M

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi Marcela,

    The dbsnp annotation was not hooked up for HC in 2.5, but it now works in 2.6.

    It's possible that BaseCounts has also not yet been hooked up; I will check and if that's the case, we'll get it done, I'll let you know in this thread.

  • JulyneJulyne FranceMember

    @Geraldine_VdAuwera said:
    Hi Marcela, it seems that this annotation is currently broken. We have not yet decided if we are going to fix it or remove it from the toolkit, since it seems it is not widely used. For now I'm afraid it is not usable, sorry.

    Hi Geraldine,

    Did you decide if you're going to fix this annotation or not? I tried it today, there is a new line named INFO=<ID=BaseCounts, Number=4... But there is no information on the SNPs lines...

    Thanks

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    It should work now if you include the bam input in your VA command line.

  • JulyneJulyne FranceMember

    Wonderful! I did not include the bam, that's why it did not work! Thank you!

Sign In or Register to comment.