The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

bam is malformed depthofcoverage

remimaglioneremimaglione Member
edited May 2013 in Ask the GATK team

Hello,

i have spend many hours trying to run GATK depthofcoverage but it never works.
last try: -T DepthOfCoverage -R /home/remi/Analyse/CNV/ERR125905/bam/Chloroplastgenomebarley.fa -I /home/remi/Analyse/CNV/ERR125905/bam/ERfiltre.bam -L /home/remi/Analyse/CNV/ERR125905/bam/ERfiltre.bed -o /home/remi/Analyse/CNV/FishingCNV_1.5.3/out/ERfiltre.bam.coverage --minMappingQuality 15 --minBaseQuality 10 --omitDepthOutputAtEachBase --logging_level INFO --summaryCoverageThreshold 5 --summaryCoverageThreshold 7 --summaryCoverageThreshold 10 --summaryCoverageThreshold 15 --summaryCoverageThreshold 20 --summaryCoverageThreshold 30 --summaryCoverageThreshold 50

My BAM header seem to be malformed.

ERROR MESSAGE: SAM/BAM file /home/remi/Analyse/CNV/ERR125905/bam/ERfiltre.bam is malformed: SAM file doesn't have any read groups defined in the header. The GATK no longer supports SAM files without read groups

here is the 1rst line of the header:

`@SQ SN:Chloroplastgenomebarley LN:136462

@PG ID:bwa PN:bwa VN:0.5.9-r16
ERR125905.35 99 Chloroplastgenomebarley 69543 29 101M = 69854 412 TTTGATCCCTCTGATCCTGTTCTGGATCCAATGTGGAGACAAGGTATGTTCGTAATTCCCTTCATGACTCGTTTAGGAATAACGGATCCTTGGGGTGGTTG D-:D?BDDDDCC-?ADCBBBDDDDD:BDD= :6 C-4<9@62@@<;:?=B??B=DC28=B&?:AA:4
@ 66DD@-@DDD?B::@-CA:5?:ADD?ADBB??`

I Have search in the forum and doc about it. I have try to reorder my header with picard:

`@HD VN:1.4 SO:unsorted

@SQ SN:Chloroplastgenomebarley LN:136462 UR:file:/home/remi/Analyse/REFGEN/Chloroplastgenomebarley.fa M5:7a7b36ef01cc1a2af1c8451ca3800f93
@PG ID:bwa PN:bwa VN:0.5.9-r16
ERR125905.35 99 Chloroplastgenomebarley 69543 29 101M = 69854 412 TTTGATCCCTCTGATCCTGTTCTGGATCCAATGTGGAGACAAGGTATGTTCGTAATTCCCTTCATGACTCGTTTAGGAATAACGGATCCTTGGGGTGGTTG D-:D?BDDDDCC-?ADCBBBDDDDD:BDD= :6 C-4<9@62@@<;:?=B??B=DC28=B&?:AA:4
@ 66DD@-@DDD?B::@-CA:5?:ADD?ADBB??
`
but no more change.

Someone can help me please ?

Regards,
Remi

`

Answers

  • CarneiroCarneiro Charlestown, MAMember

    You need to add a read group tag to your BAM to use it with the GATK. During BWA alignment (which you're using a very old version, btw) you could have added it with the -R option. Now you can still use Picard Tools to add a read group to your bam file. Without a Read Group tag, no GATK tool will run on your bam.

  • thank you for your reply,
    you're right, I did not use the-R option on my alignment with BWA.
    I'll go back on it later to tell you if all goes well.

  • remimaglioneremimaglione Member
    edited May 2013

    After a new alignment, i have had manualy the header with picard tools in my SAM (after read filter and before SAM to BAM conversion). I have try a CountRead in order to test if GATK can run my new BAM... and it works FINE. I will try to do a depthOfcoverage and tell later if all goes well.

Sign In or Register to comment.