about the reference fasta file

Hi ,I use another hg19.fasta file whose contigs are just from chr1 to chrM to create sam files ,but use the vcf files you provided whose contigs contain more .when I run RealignerTargetCreator I got an error says "input files known and reference have incompatible contigs" .I wonder how could I solve the problem .I use an hg19.fasta reference file from UCSC .Any help ,thanks.

Best Answer

Answers

  • AngelvenAngelven Member

    thank you. And another problem, I have got your vcf datas :1000G_phase1.indels.hg19.vcf dbsnp_137.hg19.vcf Mills_and_1000G_gold_standard.indels.hg19.vcf and relevant idx files from your ftp. but when I run RealignerTargetCreator with 1000G_phase1.indels.hg19.vcf and Mills_and_1000G_gold_standard.indels.hg19.vcf ,it said the Mills_and_1000G_gold_standard.indels.hg19.vcf.idx is out of date , when it tried to create a new idx file , I got an error says permission denied. I wonder why I cannot create idx file. thanks.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    This typically happens if you downloaded the index file before the vcf file, because then the file creation date on the index is older than the creation date of the vcf. The program gives you a warning because in some cases the date mismatch indicates that you're using the wrong files, but in this case you can ignore the warning. The program should work -- or is it quitting with an error?

    Regarding the permission problem when you try to create a new index, I can't really comment -- it depends what command you're using to do it and where you are trying to create the file. You may not have the permission to create files in certain directories if you're using a shared server.

Sign In or Register to comment.