Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.5 is out. See the GATK4 beta page for download and details.

Runtime Error with BaseRecalibration

Hello!
I have DNA sequence data that I'm trying to run through the GATK pipeline. One of my six samples sequenced is causing some problems. After the first error, I reran BWA, then GATK pipeline starting with the RealignerTargetCreator, then IndelRealigner, BaseRecalibrator, where it porduces the following error.

Has anyone resolved this problem before ?

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

org.broadinstitute.sting.utils.exceptions.ReviewedStingException: START (0) > (-1) STOP -- this should never happen -- call Mauricio!
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinates(ReadClipper.java:537)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinatesLeftTail(ReadClipper.java:176)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:389)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:392)
at org.broadinstitute.sting.gatk.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:244)
at org.broadinstitute.sting.gatk.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:131)
at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:230)
at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:218)
at org.broadinstitute.sting.utils.nanoScheduler.NanoScheduler$ReadMapReduceJob.run(NanoScheduler.java:471)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.4-9-g532efad):
ERROR
ERROR Please visit the wiki to see if this is a known problem
ERROR If not, please post the error, with stack trace, to the GATK forum
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: START (0) > (-1) STOP -- this should never happen -- call Mauricio!
ERROR ------------------------------------------------------------------------------------------

Best Answer

Answers

  • armenarmen Member

    Hi, I'm having the same problem when executing the best-practice pipeline after aligning reads with BWA. Getting the latest BWA version from github (as suggested in another thread) didn't help. I should use -rf BadCigar in both calls of BaseRecalibrator (one to create the recalibration table and another to create pre/post-recalibration plots), am I right? Also, should I use -rf BadCigar in PrintReads afterwards too?

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Yes, you should use -rf BadCigar in each step up to and including PrintReads. After PrintReads you won't need it any more because the bad reads will have been discarded.

  • For my problem, I just used -rf BadCigar in the BaseRecalibrator step, not in PrintReads step. And it seems OK.

  • armenarmen Member
    edited April 2013

    OK thank you @Geraldine_VdAuwera, it worked! @yinhung PrintReads without -rf BadCigar also worked for me, but it I suppose that it makes sense to use it since BaseRecalibrator was trained excluding the offending reads, and these reads may cause problems downstream the pipeline.

Sign In or Register to comment.