We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

GenomeSTRip no genotype vcf

Dear all,

I am calling SVs for WGS using the GenomeSTRiP tool. The calling is finished sucessfully for some chromosomes, but just only discovery vcf were generated for other chromosome. I run scripts with only genotyping command again, genotyping is finished within 2 seconds without error, and didn't generate genotype vcf file. I attached the command below:

ref=reference
runDir=SV3
bam=bam_chr3.list
sites=chr3.discovery.vcf
genotypes=chr3.genotypes.vcf

java -cp ${classpath} ${mx} \
org.broadinstitute.gatk.queue.QCommandLine \
-S ${SV_DIR}/qscript/SVGenotyper.q \
-S ${SV_DIR}/qscript/SVQScript.q \
-jobRunner ParallelShell -maxConcurrentRun 8 \
-gatk ${SV_DIR}/lib/gatk/GenomeAnalysisTK.jar \
--disableJobReport \
-cp ${classpath} \
-configFile ${SV_DIR}/conf/genstrip_parameters.txt \
-tempDir ${SV_TMPDIR} \
-R ${ref}/Homo_sapiens_assembly38.fasta \
-genomeMaskFile ${ref}/Homo_sapiens_assembly38.gcmask.fasta \
-genderMapFile gender.map \
-runDirectory ${runDir} \
-md ${runDir}/metadata \
-disableGATKTraversal \
-jobLogDir ${runDir}/logs \
-I ${bam} \
-vcf ${sites} \
-P chimerism.use.correction:false \
-O ${genotypes} \
-run \
|| exit 1

Are there any suggestion for this weired result?
Thank you so much for your help!

Best wishes,

CZS
Tagged:

Answers

  • bhandsakerbhandsaker Member, Broadie ✭✭✭✭

    Have you looked at what is in your chr3.discovery.vcf file?

  • chenzschenzs Member
    Hi bhandsaker,

    Thank you for your response!

    I took a look at chr3.discovery.vcf. It looks normal with SVs, one example below:

    chr3 39454 DEL_1 C <DEL> . PASS CIEND=-29,30;CIPOS=-29,30;END=187017;GSCOHERENCE=-0.619600303265919;
    chr3 134251 DEL_2 C <DEL> . PASS CIEND=-12,12;CIPOS=-12,12;END=135556;GSCOHERENCE=-3.19151997999623;

    I checked the log file and no error happend during the discovery analysis.

    Best regards,

    CZS
  • bhandsakerbhandsaker Member, Broadie ✭✭✭✭

    From what you wrote above, are you using the same run directory for multiple runs? This may cause problems such as conflicts of temporary files and such. You should use a separate run directory for each chromosome if you are genotyping by chromosome.

    Another symptom would be the existing of ".done" files in the run directory (these are files used by Queue to track which steps have succeeded already). And also in the Queue output, if it doesn't actually run the genotyping, but instead thinks this step is already done.

  • chenzschenzs Member
    Hi bhandsaker,

    Yes, i run jobs for each chromsome in seperated run directory.
    I check the logs ing the run directory. For these chromosome with no genotype vcf, the dicovery analysis run completely with ".done" in two discovery log files, but there is no SVGenotype log file.

    Thanks,

    CZS
  • bhandsakerbhandsaker Member, Broadie ✭✭✭✭

    You're going to need to provide more information, like the log files (both the Queue output and any subsidiary log files), otherwise I'm just guessing.

  • chenzschenzs Member
    I still didn't know why this issue happened. But it worked smoothly if i used the latest version.

    Thank you again for your suggestions and help!

    Best wishes,

    CZS
Sign In or Register to comment.