We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

VariantFiltration Invalid argument ' ' error

chloe_teamMycochloe_teamMyco France, LyonMember
Hello, I read a lot of posts trying to solve my problem but I didn't find anything that could help me ...
I try to hard filter my .vcf data but I have the same error while running this command:

srun gatk VariantFiltration \
-R ${ref} \
-V /${sample}_snp_recal0.vcf \
-filter "QD < 2.0" --filter-name "QD2" \
-filter "QUAL < 30.0" --filter-name "QUAL30" \
-filter "SOR > 3.0" --filter-name "SOR3" \
-filter "FS > 60.0" --filter-name "FS60" \
-filter "MQ < 40.0" --filter-name "MQ40" \
-filter "MQRankSum < -12.5" --filter-name "MQRankSum-12.5" \
-filter "ReadPosRankSum < -8.0" --filter-name "ReadPosRankSum-8" \
--excludeFiltered
-O /${sample}_snp_filtered_recal0.vcf

I tried to run the first line of the filter changing -filter by --filter-expression : same error
I tried to replace "QD < 2" by 'QD < 2' : same error
I tried to replace "QD < 2" by "QD lt 2" : same error

A USER ERROR has occurred: Invalid argument ' '.

***********************************************************************
Set the system property GATK_STACKTRACE_ON_USER_EXCEPTION (--java-options '-DGATK_STACKTRACE_ON_USER_EXCEPTION=true') to print the stack trace.
Using GATK jar /shared/mfs/data/software/miniconda/envs/gatk4-4.0.10.0/share/gatk4-4.0.10.0-0/gatk-package-4.0.10.0-local.jar
Running:
java -Dsamjdk.use_async_io_read_samtools=false -Dsamjdk.use_async_io_write_samtools=true -Dsamjdk.use_async_io_write_tribble=false -Dsamjdk.compression_level=2 -jar /shared/mfs/data/software/miniconda/envs/gatk4-4.0.10.0/share/gatk4-4.0.10.0-0/gatk-package-4.0.10.0-local.jar VariantFiltration
srun: error: cpu-node-14: task 0: Exited with exit code 1

Does anyone could help me? I'm sure it's a synthax error but I really don't know how to correct it !
thanks in advance

Chloé

Answers

Sign In or Register to comment.