Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

GenomicsDBImport error: File2TileDBBinaryException

Hello, I've been trying to get the HaplotypeCaller-in-gVCF-mode to work for a combination of exome samples, some of which are diploid individuals, and others of which are bulks with ploidies ~20. For about 20% of my chromosomes, The GenomicsDBImport step fails, with the following error message:

09:58:45.656 INFO  ProgressMeter -        Current Locus  Elapsed Minutes     Batches Processed   Batches/Minute
09:58:46.530 INFO  GenomicsDBImport - Importing batch 1 with 6 samples
terminate called after throwing an instance of 'File2TileDBBinaryException'
what():  File2TileDBBinaryException : read_one_line_fully && "Buffer did not have space to hold a line fully - increase buffer size"

I'm not sure what this means, and a google search brings up next to nothing.

I am working with mosquito exome data, 150bp PE illumina reads, GATK, java 1.8.0_181. I've been following the Broad best practices pretty closely, although I haven't managed to figure out how to bootstrap base recalibration yet.

Example GenomicsDBImport command:

gatk --java-options '-Xmx5G' GenomicsDBImport \
        --genomicsdb-workspace-path ../vcfs/combined_gvcfs/NW_021837046.1 \
        --intervals NW_021837046.1 \
        -V ../vcfs/gvcfs/BH2.gvcf \
        -V ../vcfs/gvcfs/BH3.gvcf \
        -V ../vcfs/gvcfs/K01.gvcf \
        -V ../vcfs/gvcfs/K02.gvcf \
        -V ../vcfs/gvcfs/M01.gvcf \
        -V ../vcfs/gvcfs/M02.gvcf 

Issue · Github
by bhanuGandham

Issue Number
Last Updated

Best Answer


  • jhbjhb Member

    I should also mention: I played around with increasing "--genomicsdb-segment-size" and "--genomicsdb-vcf-buffer-size", as well as the amount of memory available to java. Increasing any or all of them by a factor of about 10 had no effect, always producing the same error.

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    Hi @jhb

    I am looking into this and will get back to you shortly.
    Would you please share with me the specs of the machine you are running these tools on. It will help us narrow down the issue.

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    @jhb Are you running this on a NFS(Network File System) ?

  • jhbjhb Member

    I don't know what a network file system is--is that a synonym for a cluster? If so, then yes. If not, then I'm not sure: how do I tell?

    The nodes I'm running on are either 1) 2 x 8-core Intel Xeon E5-2680 or 2) 2 x 10-core Intel Xeon E5-2680 v2. Either way, I'm using a single core with 30 GB memory. x86_64 GNU/Linux architecture. Is this useful? Please let me know if there is any more information that I can provide.

    Thanks for your help!

  • jhbjhb Member

    Additional information: the bulks seem to be the root of the problem, as running GenomicsDBImport only on the diploid individuals of the sample set produces none of these errors.

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    Hi @jhb

    This error requires adjusting the buffer size, but unfortunately that option is not available in GATK. I have created a github issue ticket to fix this. You can follow progress on this issue here: https://github.com/broadinstitute/gatk/issues/6150

  • jhbjhb Member

    Thanks a lot, I'll give that a try and report back!

  • jhbjhb Member

    It worked, thanks!

Sign In or Register to comment.