Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

ERROR LiftOverVcf GVCF

Hi to all,

I have GVCFs(one for each chromosome) from reference genome b37 and I want to liftover to hg38.
I am using the correct references genomes and the chain file b37tohg38.
But when I run it I have the following error:
##########
INFO 2019-09-03 09:23:52 LiftOver Interval 21:10400001-10400015 failed to match chain 22 because intersection length 14 < minMatchSize 15.0 (0.93333334 < 1.0)
INFO 2019-09-03 09:23:52 LiftOver Interval 21:10647820-10697986 failed to match chain 22 because intersection length 77 < minMatchSize 50167.0 (0.0015348735 < 1.0)
INFO 2019-09-03 09:23:52 LiftOver Interval 21:10647820-10697986 failed to match chain 158 because intersection length 90 < minMatchSize 50167.0 (0.001794008 < 1.0)
[Tue Sep 03 09:23:52 CEST 2019] picard.vcf.LiftoverVcf done. Elapsed time: 0.22 minutes.
Runtime.totalMemory()=3924295680
To get help, see http://broadinstitute.github.io/picard/index.html#GettingHelp
java.lang.ArrayIndexOutOfBoundsException: -1
at picard.util.LiftoverUtils.lambda$leftAlignVariant$4(LiftoverUtils.java:379)
at java.util.stream.Collectors.lambda$groupingBy$45(Collectors.java:907)
at java.util.stream.ReduceOps$3ReducingSink.accept(ReduceOps.java:169)
at java.util.HashMap$ValueSpliterator.forEachRemaining(HashMap.java:1625)
##########

Honestly I have no idea what can happen, may be I can't use it with GVCFs files?¿
If anyone can give me his/her feedback, it would be great.

THANK YOU!
Tagged:

Answers

  • bshifawbshifaw Member, Broadie, Moderator admin

    Please include your gatk version, Java versions, and command used.

  • Hi,
    Java version: Java/1.8.0_162
    GATK version: gatk-package-4.1.3.0-local.jar

    The code:
    java -Xmx4g -Djava.io.tmpdir=tmp -jar gatk-package-4.1.3.0-local.jar \
    LiftoverVcf \
    -I=sample.chr21.g.vcf.gz \
    -O=sample.chr21.hg38.g.vcf.gz \
    -C=b37ToHg38.over.chain.gz \
    -REJECT=sample.chr21.reject.g.vcf.gz \
    -R=/reference/Homo_sapiens_assembly38.fasta \
    -TMP_DIR=tmp


    Thank you!
  • bshifawbshifaw Member, Broadie, Moderator admin

    I spoke with my team and they mentioned there may have been some issues with older chain files. Where did you get your current chain files from?
    Also, LiftoverVcf should word with gvcf.

  • From here:
    https://raw.githubusercontent.com/broadinstitute/gatk/master/scripts/funcotator/data_sources/gnomAD/b37ToHg38.over.chain
    Or where can I take the last chain version for b37toHg38?
    My samples are WGS.

    Thank!!
  • bshifawbshifaw Member, Broadie, Moderator admin
    edited September 10

    That looks to be the right file. After a bit of digging it looks this error might be associated with an issue ticket that has been reported on git here. They both took place in the leftAlignVariant function in LiftoverUtils, and output the java.lang.ArrayIndexOutOfBoundsException: -1 message.
    Do you only get the message when lifting over the sample type mentioned in the issue ticket?

    If you could provide a sample VCF that crashes that would be very helpful for verifying the problem and any potential fix.

    Post edited by bshifaw on
  • Hi again,

    Yes, I red the issue ticket that have you sent(still opened) and I got only this message as it is mentioned.
    I can not send to you de whole vcf, but I can send you a part of it(without the header, but it is the standard one for b37 reference genome). And when you lift over it appers the same error "java.lang.ArrayIndexOutOfBoundsException: -1".
    How can I send to you?

    Thank you!
  • bshifawbshifaw Member, Broadie, Moderator admin

    Part of the file is fine, follow the instructions here to submit a file.

  • Sorry, but I can't connect to ftp.broadinstitute.org for uploading the data.
    I have tried a few times and it doens't connect.
  • bshifawbshifaw Member, Broadie, Moderator admin

    I think there is a limit to the number of users that can connect to the FTP, try again at a different time.

  • It doesn't connect yet, I have tried many times
Sign In or Register to comment.