Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Can I disable local reassembly and realignment?

KuroKamiKuroKami ChinaMember

Hello,

I want to dentify short variants in RNAseq data. But I find HaplotypeCaller introduces many unusual alignments (see the raw bam and bamout file).

Can I disable local reassembly and realignment or any ways to solve this problem?

Thanks!

My GATK version is 4.1.2.0.
My commands are:
gatk SplitNCigarReads -R ref.fa -I STAR.mapped.remove_dup.bam -O SplitN.bam
gatk HaplotypeCaller -R ref.fa -I SplitN.bam -O output.g.vcf.gz -ERC GVCF -bamout bamout.bam

Tagged:

Best Answer

Answers

  • KuroKamiKuroKami ChinaMember

    @SkyWarrior said:
    No. You may try UnifiedGenotyper from GATK3 or use other tools to call variants such as bcftools or freebayes.

    Can you also check to see if your reads still contain softclipped bases? Alternatively you may try a different aligner such as Tophat to see if the problem still persists.

    Oh, Yes, It's due to the soft clipped bases, why GATK4 didn't use hard clip as GATK3 ?

  • SkyWarriorSkyWarrior TurkeyMember ✭✭✭

    You may need to add parameter to omit softclipped bases in haplotypecaller for RNAseq.

  • KuroKamiKuroKami ChinaMember

    @SkyWarrior said:
    No. You may try UnifiedGenotyper from GATK3 or use other tools to call variants such as bcftools or freebayes.

    Can you also check to see if your reads still contain softclipped bases? Alternatively you may try a different aligner such as Tophat to see if the problem still persists.

    Sorry, but I didn't find how to using hard clip instead of soft clip in GATK4.

  • SkyWarriorSkyWarrior TurkeyMember ✭✭✭
    edited July 5
    --dont-use-soft-clipped-bases:Boolean     Do not analyze soft clipped bases in the reads  Default value: false. Possible values:{true, false}
    

    add

    --dont-use-soft-clipped-bases true
    

    to your command line.
    This should be the parameter for HaplotypeCaller

  • KuroKamiKuroKami ChinaMember

    @SkyWarrior said:

    --dont-use-soft-clipped-bases:Boolean     Do not analyze soft clipped bases in the reads  Default value: false. Possible values:{true, false}
    

    add

    --dont-use-soft-clipped-bases true
    

    to your command line.
    This should be the parameter for HaplotypeCaller

    Thanks a lot!

Sign In or Register to comment.