Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Error wit BaseRecalibrator: The stop position ... is less than start ...

I am using GATK version 2.4.9. When trying to execute BaseRecalibrator I get this message:

ERROR MESSAGE: Badly formed genome loc: Parameters to GenomeLocParser are incorrect:The stop position 4580 is less than start 4581 in contig chr1

I'm not specifying any of the advanced options, just an input BAM, the reference genome and a BED file for the -knownSites argument. The BAM file has been correctly validated with Picard and I've checked the BED and all stop positions are greater or equal to the start positions.

I also tried with an older version of GATK so that I could use CountCovariates, but it gave a similar error (same error with different start and stop positions).

The exact call to the method is:

java -Xmx4g -jar GenomeAnalysisTK.jar -T BaseRecalibrator -I XXXX.marked.realigned.fixed.bam -R hg18KO.fa -knownSites dbsnp130_hg18_KO.bed -o XXXX_recal_data.grp

Any help would be greatly appreciated.

Mikel

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi Mikel,

    Keep in mind that the BED format is 0-based for the start coordinates, so coordinates taken from 1-based formats should be offset by 1. This may explain the error you're getting.

Sign In or Register to comment.