Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

SortVcf

annabiannabi Member
edited May 30 in Ask the GATK team
The order of file Mills_and_1000G_gold_standard.indels.hg38.vcf is not same with my genome fasta file,so I need to reorder it,I use SortVcf to do it.Before I run it,I run UpdateVcfSequenceDictionary first.My scripts is as follows:

java -jar /data/share-disk/kvm72/yangzhen/programe/picard.jar UpdateVcfSequenceDictionary \
I=Mills_and_1000G_gold_standard_rename.indels.hg38.vcf \
O=Mills_and_1000G_gold_standard_dict.indels.hg38.vcf \
SEQUENCE_DICTIONARY=/data2/gminix/pipeline/toolkits/RNA_seq_SNP-INDEL/data/hg38v1.dict

java -jar /data/share-disk/kvm72/yangzhen/programe/picard.jar SortVcf \
I=Mills_and_1000G_gold_standard_dict.indels.hg38.vcf \
O=Mills_and_1000G_gold_standard_reorder.indels.hg38.vcf \
SEQUENCE_DICTIONARY=/data2/gminix/pipeline/toolkits/RNA_seq_SNP-INDEL/data/hg38v1.dict

It didn't give any error,but just counld not finish it.The report is shown in the picture:


It stops there and no longer runs,what can be the problem?
Tagged:

Best Answer

Answers

  • annabiannabi Member
    edited May 30
    Sorry,my English is poor,and tenses maybe wrong!
  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    Hi @annabi

    Which version of picard are you using? Couple of things you can try:
    1) Try running this again and see if it stops at the same read position and then verify that position to see if there is anything weird about it.
    2) Run Sort vcf without the SEQUENCE_DICTIONARY option and see if that resolves the error.

  • annabiannabi Member
    edited May 31
    1)I tried the first method,and it did stop at the same read position.And I tried the second one,but it didn't work.
    2)I tried the latest version picard,it didn't work too.
  • annabiannabi Member
    It is solved! I run ValidateVariants and get an error:Input Vcf files reads and reference have incompatible contigs,and I renam the contigs and it can run through now.Thank you very much!
  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin
Sign In or Register to comment.