Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Mutect2 analysis results in a empty output bam file and a vcf file with only the header

Hello, I write to report a problem I encountered while using Mutect2.

In short, I performed pre-processing on two sets of paired-end fastq files (control and tumor) according to the gatk4 best practices. Then I perform Mutect2 analysis with this command:

gatk --java-options "-Xmx2g" Mutect2 -R /path/ucsc.hg19.fasta -I S3.bam -I S1.bam -tumor tumor -normal ctrl --germline-resource /path/af-only-gnomad.raw.sites.hg19.vcf --af-of-alleles-not-in-resource 0.001 -disable-read-filter MateOnSameContigOrNoMappedMateReadFilter -O 1_somatic_m2.vcf.gz -bamout 2_tumor_normal_m2.bam -L exons.bed

I do not get any errors, the last lines of the st output look like this:

20:53:49.380 INFO ProgressMeter - chrUn_gl000249:36601 361.1 13527466 37460.5
20:53:49.380 INFO ProgressMeter - Traversal complete. Processed 13527466 total regions in 361.1 minutes.
20:53:49.397 INFO VectorLoglessPairHMM - Time spent in setup for JNI call : 10.407843391
20:53:49.397 INFO PairHMM - Total compute time in PairHMM computeLogLikelihoods() : 951.4249066770001
20:53:49.397 INFO SmithWatermanAligner - Total compute time in java Smith-Waterman : 3230.28 sec
20:53:49.431 INFO Mutect2 - Shutting down engine
[May 3, 2019 8:53:49 PM CEST] org.broadinstitute.hellbender.tools.walkers.mutect.Mutect2 done. Elapsed time: 361.18 minutes.
Runtime.totalMemory()=2141716480
Tool returned:
SUCCESS


However the output bam file and is empty, and the output vcf file contains only the header; what I am doing wrong?

I also tried to run the command without the -L flag.

Thank you in advance.
Tagged:

Best Answer

Answers

Sign In or Register to comment.