Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Mutect2 "--mitochondria" flag doesn't work

DLFDLF Member
edited April 11 in Ask the GATK team
First of all, since this is my first question on the forum, I wanted to thank you for all the help so far and the help that I will definitely get in the future.
Now to the actual question: I am working with mitochondrial DNA and I am trying to call variants with Mutect2, using the latest (V4.1.1.0) version of GATK. The problem is however that it seems that neither the "--mitochondria" nor "--median-autosomal-coverage" flags are recognised. In fact, in the "Argument list/details" section of the web page of the tool, neither of them are included. But in the example just above -(iii) Mitochondrial mode-, they are.
So, is the "--mitochondria" argument not implemented in GATK yet? Or am I missing something else?
Btw, when I tried to run it with the old "-mitochondria-mode" flag which is included in the argument list, it works. The output returns "##MutectVersion=2.2", is that right or it should be an older version?
Thank you
PanaZ
Post edited by DLF on

Best Answer

Answers

  • davidbendavidben BostonMember, Broadie, Dev ✭✭✭

    @DLF Thanks for trying out mitochondria mode! GATK 4.1.1.0 has a --mitochondria-mode argument for Mutect2 and an --autosomal-coverage argument in FilterMutectCalls. Could you point us to the example you are referring to so we can update the documentation?

    ##MutectVersion=2.2 is correct.

  • DLFDLF Member
    Ok, thanks! I thought these arguments had changed with GATK 4.1.

    Unfortunately, it seems that I need to be part of the forum "a little while longer before I can post links". I am referring to the Mutect2 documentation and, more precisely, to example 3:

    ```
    (iii) Mitochondrial mode

    Mutect2 automatically sets parameters appropriately for calling on mitochondria with the --mitochondria flag. Specifically, the mode sets –-initial-tumor-lod to 0, –-tumor-lod-to-emit to 0, --af-of-alleles-not-in-resource to 4e-3, and the advanced parameter --pruning-lod-threshold to -4.

    gatk Mutect2 \
    -R reference.fa \
    -L chrM \
    --mitochondria \
    --median-autosomal-coverage 30 \
    -I mitochondria.bam \
    -O mitochondria.vcf.gz


    Setting the advanced option --median-autosomal-coverage argument (default 0) activates a recommended filter against likely erroneously mapped NuMTs (nuclear mitochondrial DNA segments). For the value, provide the median coverage expected in autosomal regions with coverage. The mode accepts only a single sample, which can be provided in multiple files.
    ```
  • davidbendavidben BostonMember, Broadie, Dev ✭✭✭
    Accepted Answer

    Thanks @DLF, a fix to the usage example is now under review: https://github.com/broadinstitute/gatk/pull/5890.

  • ashokpatowaryashokpatowary Member

    @davidben while using long read cDNA sequences how significant —autosomal-coverage argument is?

  • davidbendavidben BostonMember, Broadie, Dev ✭✭✭

    @ashokpatowary Good question. If your reads are long enough to prevent NuMT mapping errors you can omit the argument entirely to skip this filter. I believe that in our experience PacBio reads eliminate these errors, but how long are your reads?

    By the way, when the filter is needed, it's important to give the right value of --autosomal-coverage, but we're working on a more sophisticated and robust method to filter NuMTs.

  • ashokpatowaryashokpatowary Member

    @davidben thanks for your response. majority of my reads are over 1500bp.
    Whats the best way to calculate — autosomal-coverage for cDNA reads since they are not uniformly distributed?
    Thanks

  • davidbendavidben BostonMember, Broadie, Dev ✭✭✭

    @ashokpatowary Currently if the coverage varies a lot around its median value the filter won't be very effective. Fortunately, your reads should easily be long enough to distinguish NuMTs from true mitochondrial sequence, and if I were you I would leave the argument unspecified in order to turn off the filter.

Sign In or Register to comment.