Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

GATK 4.1.1.0 Mutect2 doesn't emit a real variant

amjaddamjadd FinlandMember

Hello GATK team,

I have been trying the brand new Mutect2 v4.1.1.0 on ctDNA samples with high coverage. I noticed one case where Mutect2 v4.1.0.0 detected a variant, but the new version didn't even emit the mismatch.

Here is the original command I used:

gatk Mutect2 -R reference.fasta -I normal.bam \
-O variants.vcf.gz --germline-resource gnomadhg19.vcf.gz \
--panel-of-normals pon.vcf.gz -L targets.interval_list \
-ip 300 -normal normalSample -I tumor1.bam \
-I tumor2.bam -I tumor3.bam -I tumor4.bam

When I realized the missing variant, I reran Mutect2 with the following additional parameters, but that didn't help.

--force-active true --tumor-lod-to-emit 0 --initial-tumor-lod 0

Here is an IGV snapshot of the variant (it exists in only one tumor sample: Ref: 820, Alt: 29, N: 2)

The reads in the upper part are from the original bam and in the lower part from the bam file emitted by Mutect2

Thank you for your help

Tagged:

Best Answer

Answers

  • amjaddamjadd FinlandMember

    Update: The variant was detected after setting --max-reads-per-alignment-start 0.
    And now the reported counts better represent the depth of the samples.
    I'm looking forward to seeing the blog about ctDNA and parameter recommendations for high-depth samples.

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    @amjadd

    I am glad you were able to figure it out. I have asked the dev for an explanation of why that happens and will get back to you shortly.

  • amjaddamjadd FinlandMember

    Thank you for answering @bhanuGandham
    All clear

Sign In or Register to comment.