We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

DeNovo pipeline, CalculateGenotypePoster

Hi @gauthier,

maybe this post is related to this post

When I'm going to run the DeNovo pipeline with the "--skip-population-priors" Calculate Genotype Posteriors (CGP) option I'have in general few high and low DeNovo variants...

SelectVariants... -sn proband -sn mother -sn father
CalculateGenotypePosteriors -ped --skip-population-priors
VariantFiltration -G-filter 'GQ < 20.0'
VariantAnnotator -ped -A PossibleDeNovo

35 DeNovo (21 HiConfDeNovo, 14 LoConfDeNovo)

But when I'm going to include in the Calculate Genotype Posteriors the "-supporting" option with -ped and without the "--skip-population-priors" option, I have:

395 DeNovo (24 HiConfDeNovo, 371 LoConfDeNovo)

Example:

GATK v4.0.10.0, WES data, trios

Before CGP
chr16 14013455 . C T 68.23 . AC=2;AF=1.00;AN=2;DP=2;ExcessHet=0.0560;FS=0.000;InbreedingCoeff=0.0814;MQ=60.00;QD=34.11;SOR=0.693 GT:AD:DP:GQ:PL 1/1:0,2:2:6:59,6,0 ./.:0,0:0:.:0,0,0 ./.:0,0:0:.:0,0,0

After CGP (with the "-supporting" option)
chr16 14013455 . C T 68.23 PASS AC=1;AF=0.167;AN=6;DP=2;ExcessHet=0.0560;FS=0.000;InbreedingCoeff=0.0814;MQ=60.00;PG=0,21,47;QD=34.11;SOR=0.693;hiConfDeNovo=WES_12-436bis GT:AD:DP:GQ:PL:PP 0/1:0,2:2:20:59,6,0:32,0,20 0/0:0,0:0:21:0,0,0:0,21,47 0/0:0,0:0:21:0,0,0:0,21,47

Without the -supporting option this variant is excluded...

Any advice if I want to use CGP with higher stringency?

Many thanks

Answers

Sign In or Register to comment.