The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!

You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?

1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?

Then follow instructions in Article#1894.

Formatting tip!

Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

MaxInsertSize Read filter

aeonsimaeonsim Member
edited March 2013 in Ask the GATK team

Is it possible to set the maximum insert size allowed for the MaxInsertSize read filter? Looking at the documentation at it's set with a default value of 1,000,000 which is too high for what we want.

If it is possible how does one set it I've tried several different combinations and nothing seems to work, apart from leaving it with it's default value. Reading the doc it looks like --maxInsertSize 1000 should work, but GATK refuses to accept that complaining the 1000 is an unknown argument.

I've tried -rf MaxInsertSize GATK runs with that as long as I don't try to supply a number to adjust the default value.
So -rf MaxInsertSize 1000, -rf MaxInsertSize=1000,-maxInsertSize=1000,-maxInsertSize 1000 etc don't work though looking at the docs I would have thought at least one of them would have.


Best Answer


Sign In or Register to comment.