user error message for HaplotypeCaller in GVCF mode

I am receiving this error message when I run HaplotypeCaller:

'''A USER ERROR has occurred: Read M02780:305:000000000-C4988:1:1102:23167:21145_1:N:0:16%26M02780:305:000000000-C4988:1:1102:23167:21145_2:N:0:16_(reversed) NC_007793:117448-117692 is malformed: read starts with deletion. Cigar: 13H2P1D244M. Although the SAM spec technically permits such reads, this is often indicative of malformed files.'''

I have tried multiple files, and I get the same error for all of them. A vcf file is produced, but it is truncated. When I run the same command without -ERC GVCF, it completes without an error and produces a full vcf file.

I am using Illumina data, 150bp PE, DNA bacterial origin (S. aureus). My pipeline is as follows: run the PE fastq with Bowtie2, then sort with samtools, then AddOrReplaceReadGroups and MarkDuplicates with picard, then index with samtools, and finally ValidateSamFile with picard. All of the files pass the validation without any errors.

I have also tried various ReadFilter flags including WellformedReadFilter, MappedReadFilter, GoodCigarReadFilter, ValidAlignmentStartReadFilter, but get the same message.

I am running Java version 1.8.0_121 on a Mac OS 10.13.1.

stacktrace:

'''at org.broadinstitute.hellbender.utils.locusiterator.AlignmentStateMachine.stepForwardOnGenome(AlignmentStateMachine.java:274)
at org.broadinstitute.hellbender.utils.locusiterator.ReadStateManager.addReadsToSample(ReadStateManager.java:258)
at org.broadinstitute.hellbender.utils.locusiterator.ReadStateManager.collectPendingReads(ReadStateManager.java:177)
at org.broadinstitute.hellbender.utils.locusiterator.LocusIteratorByState.lazyLoadNextAlignmentContext(LocusIteratorByState.java:315)
at org.broadinstitute.hellbender.utils.locusiterator.LocusIteratorByState.hasNext(LocusIteratorByState.java:252)
at org.broadinstitute.hellbender.tools.walkers.haplotypecaller.ReferenceConfidenceModel.getPileupsOverReference(ReferenceConfidenceModel.java:490)
at org.broadinstitute.hellbender.tools.walkers.haplotypecaller.ReferenceConfidenceModel.calculateRefConfidence(ReferenceConfidenceModel.java:251)
at org.broadinstitute.hellbender.tools.walkers.haplotypecaller.HaplotypeCallerEngine.referenceModelForNoVariation(HaplotypeCallerEngine.java:688)
at org.broadinstitute.hellbender.tools.walkers.haplotypecaller.HaplotypeCallerEngine.callRegion(HaplotypeCallerEngine.java:522)
at org.broadinstitute.hellbender.tools.walkers.haplotypecaller.HaplotypeCaller.apply(HaplotypeCaller.java:240)
at org.broadinstitute.hellbender.engine.AssemblyRegionWalker.processReadShard(AssemblyRegionWalker.java:291)
at org.broadinstitute.hellbender.engine.AssemblyRegionWalker.traverse(AssemblyRegionWalker.java:267)
at org.broadinstitute.hellbender.engine.GATKTool.doWork(GATKTool.java:966)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.runTool(CommandLineProgram.java:139)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMainPostParseArgs(CommandLineProgram.java:192)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:211)
at org.broadinstitute.hellbender.Main.runCommandLineProgram(Main.java:160)
at org.broadinstitute.hellbender.Main.mainEntry(Main.java:203)
at org.broadinstitute.hellbender.Main.main(Main.java:289)'''



I would very much appreciate your help.

Thank you,

Rebecca

Answers

  • rebeccaroserebeccarose Member
    I figured out the problem: the version of Bowtie2 that I was using apparently produced a problem in the bam file. I reran the fastq files using version 2.3.4.3 via command line and it works fine.
Sign In or Register to comment.