Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

spark-master is not a recognized option

Hello,

I am trying to run Mutect2 (GATK v4.0.10.0) the spark-runner LOCAL mode. As I explain below I am failing to correctly request the number of local cores.

This is how I run Mutect2 with the default --spark-runner LOCAL mode

```
gatk Mutect2 \
-R GRCh38_full_analysis_set_plus_decoy_hla.fa \
--tumor-sample HCC1143_tumor \
--input hcc1143_N_subset50K.bam \
--input hcc1143_T_subset50K.bam \
--output mutect2.vcf \
-- --spark-runner LOCAL
```

Then for testing I book a one CPU machine in our cluster and I see Spark Runner is trying to use its default sparkMaster value of local[4].

The following two lines from Mutect2 logs confirm me the above
14:34:43.360 INFO IntelPairHmm - Available threads: 1
14:34:43.360 INFO IntelPairHmm - Requested threads: 4


If I try to request one CPU in gatk like this:

```
gatk Mutect2 \
-R GRCh38_full_analysis_set_plus_decoy_hla.fa \
--tumor-sample HCC1143_tumor \
--input hcc1143_N_subset50K.bam \
--input hcc1143_T_subset50K.bam \
--output mutect2.vcf \
-- --spark-runner LOCAL --spark-master local[1]
```

I get the error:
A USER ERROR has occurred: spark-master is not a recognized option


Any help to correctly use --spark-master to effectively select the number of cores will be very appreciated

Thanks a lot,
Jorge

Answers

Sign In or Register to comment.