The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

Undocumented change in 2.4? (-A DepthOfCoverage)

TechnicalVaultTechnicalVault Cambridge, UKMember
edited March 2013 in Ask the GATK team

Just in the process of updating our pipeline from v2.3-4-gb8f1308 Lite to v2.4-7-g5e89f01 Academic and have run into a small issue. The command line:

-T UnifiedGenotyper -glm SNP -R /lustre/scratch111/resources/ref/Homo_sapiens/1000Genomes_hs37d5/hs37d5.fa -I /lustre/scratch111/projects/helic/vcf-newpipe/lists/chr1-pooled.list --alleles /lustre/scratch111/projects/helic/vcf-newpipe/pooled/1/1:1-1000000.snps.vcf.gz -L 1:1-1000000 -U LENIENT_VCF_PROCESSING -baq CALCULATE_AS_NECESSARY -gt_mode GENOTYPE_GIVEN_ALLELES -out_mode EMIT_ALL_SITES --standard_min_confidence_threshold_for_calling 4.0 --standard_min_confidence_threshold_for_emitting 4.0 -l INFO -A QualByDepth -A HaplotypeScore -A MappingQualityRankSumTest -A ReadPosRankSumTest -A FisherStrand -A InbreedingCoeff -A DepthOfCoverage -o /lustre/scratch111/projects/helic/vcf-newpipe/pooled/1/1:1-1000000.asnps.vcf.gz.part.vcf.gz

This worked in 2.3.4. But now gives:

Invalid command line: Argument annotation has a bad value: Class DepthOfCoverage is not found; please check that you have specified the class name correctly

I've looked at the release notes but it's not giving me a clue as to what has changed. Has the DepthOfCoverage annotation now been dropped? I've checked and I can reproduce this on the latest nightly (nightly-2013-03-11-g184e5ac)

Post edited by TechnicalVault on

Best Answer

Answers

  • TechnicalVaultTechnicalVault Cambridge, UKMember

    Just been looking through VariantAnnotator --list and noticed there is now -A Coverage. I assume this is -A DepthOfCoverage renamed? Could this be added to the release notes please?

    P.S. Small wishlist feature request, could you please make it possible to run VariantAnnotator --list without providing a -R reference and -V variants?

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Ah, thanks for pointing that out, Tommy. I'll fix that ASAP.

  • tommycarstensentommycarstensen United KingdomMember
    edited May 2013

    @TechnicalVault I've had some problems with VA 2.4 myself. I have created this list of annotation equivalents:

    QD QualByDepth

    MQRankSum MappingQualityRankSumTest

    ReadPosRankSum ReadPosRankSumTest

    MQ RMSMappingQuality

    FS FisherStrand

    DP Coverage (previously DepthOfCoverage)

    These pages currently do not reflect the annotation changes, but it's an impossible task to update all of them:

    http://www.broadinstitute.org/gatk/guide/article?id=1268

    http://www.broadinstitute.org/gatk/guide/article?id=1259

    http://www.broadinstitute.org/gatk/gatkdocs/org_broadinstitute_sting_gatk_walkers_variantrecalibration_VariantRecalibrator.html

    http://gatkforums.broadinstitute.org/discussion/39/variant-quality-score-recalibration-vqsr

    Thanks.

    P.S. @Geraldine_VdAuwera I have the same feature as Martin on my wishlist (VA --list without full command line)

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Thanks Tommy, I fixed the mentions of Coverage in those docs. No task is impossible -- but it sure helps to have someone point these out! FYI, I also put in a symlink so that if anyone use the old DepthOfCoverage annotator doc link, they will be redirected to the appropriate Coverage page.

    I'm looking into a solution for the VA --list issue. I tinkered with making a separate listing tool but the call is awkwardly long:

    java -cp GenomeAnalysisTK.jar org.broadinstitute.sting.tools.ListAnnotations
    

    Comments welcome, but I'm guessing that's not really going to make anyone happy. It's difficult to make this a priority though, because the annotations are all listed in the online docs, so it's not like there's no way to find them. But I understand sometimes you just want to get a quick list from command line. So, stay tuned...

  • TechnicalVaultTechnicalVault Cambridge, UKMember

    In the release notes for 2.5 it lists under variant annotator is has listed: "Can now use the --list option without needing a full valid command-line." [1] However as of 2.5-2 it still doesn't seem to work so I'm not quite sure what was changed [2].

    [1] http://gatkforums.broadinstitute.org/discussion/2572/release-notes-for-gatk-version-2-5#latest

    [2] test command line: java -jar GenomeAnalysisTK.jar -T VariantAnnotator --list

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Ah, I think that was an error we made in compiling the release notes. There is now a way to list annotations, but the command line is

    java -cp GenomeAnalysisTK.jar org.broadinstitute.sting.tools.ListAnnotations
    

    which is admittedly a little awkward, so we're still looking into making --list work by itself.

  • TechnicalVaultTechnicalVault Cambridge, UKMember

    Just tried that on GATK 2.5-2 and got:

    java -cp GenomeAnalysisTK.jar org.broadinstitute.sting.tools.ListAnnotations
    INFO  15:54:36,033 HelpFormatter - ------------------------------------------------------------ 
    INFO  15:54:36,035 HelpFormatter - Program Name: org.broadinstitute.sting.tools.ListAnnotations 
    INFO  15:54:36,038 HelpFormatter - Program Args:  
    INFO  15:54:36,039 HelpFormatter - Date/Time: 2013/05/22 15:54:36 
    INFO  15:54:36,039 HelpFormatter - ------------------------------------------------------------ 
    INFO  15:54:36,039 HelpFormatter - ------------------------------------------------------------ 
    Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/javadoc/ProgramElementDoc
        at org.broadinstitute.sting.tools.ListAnnotations.execute(ListAnnotations.java:69)
        at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:245)
        at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:152)
        at org.broadinstitute.sting.tools.ListAnnotations.main(ListAnnotations.java:76)
    Caused by: java.lang.ClassNotFoundException: com.sun.javadoc.ProgramElementDoc
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 4 more
    
  • TechnicalVaultTechnicalVault Cambridge, UKMember

    On latest nightly I get the following error message (but this may just be because it's a nightly:

    java -cp GenomeAnalysisTK.jar org.broadinstitute.sting.tools.ListAnnotations
    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/broadinstitute/sting/tools/ListAnnotations : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$000(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
    Could not find the main class: org.broadinstitute.sting.tools.ListAnnotations.  Program will exit.
    
  • CarneiroCarneiro Charlestown, MAMember

    this is a bug on our side. We will look into it. Thank you.

Sign In or Register to comment.