The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!

You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?

1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?

Then follow instructions in Article#1894.

Formatting tip!

Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Picard 2.10.4 has MAJOR CHANGES that impact throughput of pipelines. Default compression is now 1 instead of 5, and Picard now handles compressed data with the Intel Deflator/Inflator instead of JDK.
GATK version 4.beta.2 (i.e. the second beta release) is out. See the GATK4 BETA page for download and details.

UnifiedGenotyper always give BGZF file has invalid uncompressedLength: -1792842732


I running a pipline for exome data. I have 7 exome samples. When the pipeline arrive at the UnifiedGenotyper i always get the error my bam files are malformed.

MESSAGE: SAM/BAM file /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261951.recal.bam is malformed: BGZF file has invalid uncompressedLength: -1792842732

All the bam files have are serveral GB big. So I do not get i why the uncompressed length is negative. Here is what is executed:

java -Xmx8g -jar /lib/gatk/GenomeAnalysisTK-2.1-13-g1706365/GenomeAnalysisTK.jar -T UnifiedGenotyper -R /tmp/db99fcb54f49eea7ce46ff16a802f7ac/human_g1k_v37.fasta -nt 30 -glm BOTH -A AlleleBalance -A DepthOfCoverage -A FisherStrand -D /tmp/db99fcb54f49eea7ce46ff16a802f7ac/dbsnp_135.b37.vcf -o samples.variants.raw.vcf -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261951.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261953.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261952.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261954.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261950.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261955.recal.bam -I /tmp/db99fcb54f49eea7ce46ff16a802f7ac/ISDBM261956.recal.bam




  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Hi Robin, it sounds like the previous step is creating corrupted bams. Can you post all the command lines that are used in your pipeline?

  • Hey Geraldine thanks for looking at it.

    Meanwhile it is already solved i think(pipeline is still running). I am using an automated pipeline that was generating two times for each sample the same bam. That was a bug. But the index was done only for one of the two, and apparently the bam files generated by the gatk printreads are not the same for same input arguments. They differ some bytes. Cause of the difference between the bam files I was using the wrong index file.

    So the generated bams are alright, the error message is just not clear.



  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    OK, glad to hear your problem seems to be solved. I'll see if we can improve the error message.

Sign In or Register to comment.