Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office on October 14, 2019, due to the U.S. holiday. We will return to monitoring the forum on October 15.

missing ProgramElementDoc

Hi,

I'm trying to run the depth of coverage analysis with the following command:

java -jar /usr/local/gatk/GenomeAnalysisTK.jar -T DepthOfCoverage -I 6293-BRCA_S7.bam -R hg19.fasta

I get this trace:

INFO 10:52:31,682 HelpFormatter - --------------------------------------------------------------------------------
INFO 10:52:31,683 HelpFormatter - The Genome Analysis Toolkit (GATK) v2.3-4-g57ea19f, Compiled 2012/12/20 15:09:50
INFO 10:52:31,683 HelpFormatter - Copyright (c) 2010 The Broad Institute
INFO 10:52:31,683 HelpFormatter - For support and documentation go to http://www.broadinstitute.org/gatk
INFO 10:52:31,686 HelpFormatter - Program Args: -T DepthOfCoverage -I 6293-BRCA_S7.bam -R hg19.fasta
INFO 10:52:31,686 HelpFormatter - Date/Time: 2012/12/27 10:52:31
INFO 10:52:31,686 HelpFormatter - --------------------------------------------------------------------------------
INFO 10:52:31,686 HelpFormatter - --------------------------------------------------------------------------------
INFO 10:52:31,696 GenomeAnalysisEngine - Strictness is SILENT
INFO 10:52:31,786 GenomeAnalysisEngine - Downsampling Settings: No downsampling
INFO 10:52:31,790 SAMDataSource$SAMReaders - Initializing SAMRecords in serial
INFO 10:52:31,799 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.01

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

java.lang.NoClassDefFoundError: com/sun/javadoc/ProgramElementDoc
at org.broadinstitute.sting.utils.exceptions.UserException$LexicographicallySortedSequenceDictionary.(UserException.java:354)
at org.broadinstitute.sting.utils.SequenceDictionaryUtils.validateDictionaries(SequenceDictionaryUtils.java:130)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.validateSourcesAgainstReference(GenomeAnalysisEngine.java:823)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.getReferenceOrderedDataSources(GenomeAnalysisEngine.java:907)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.initializeDataSources(GenomeAnalysisEngine.java:765)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute(GenomeAnalysisEngine.java:259)
at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(CommandLineExecutable.java:113)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:237)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:147)
at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:94)
Caused by: java.lang.ClassNotFoundException: com.sun.javadoc.ProgramElementDoc
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
... 10 more

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.3-4-g57ea19f):

I'm in debian wheezy, I've tried with:

/usr/lib/jvm/java-1.6.0-openjdk-amd64
/usr/lib/jvm/java-1.7.0-openjdk-amd64

and also with the java-sun binary.
Maybe the problem is due to my lack of experience with java. Any advice?
Best regards,

Jose Blanca

Best Answer

Answers

  • jblancajblanca Member

    Thanks for the answer, it really helps.
    I was using your precompiled GATK.
    I tried with OpenJDK and with the sun java and in both had the same problem. I think I'll give up for the time being because I completely ignore everything about the java ecosystem. I was trying to compare GATK with bedtools.
    Best regards, and thanks again for you answer.

Sign In or Register to comment.