Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

I have been running gatk (v version 1.4-17-gd5199db)) with java 1.7.0

I have been running gatk (v version 1.4-17-gd5199db)) with java 1.7.0 and all seems well. In fact, running with previous java version (early 1.6 I think), was not working properly ...eg skipping chromosomes in realignment etc. As you say gatk not supporting java 1.7 is there something that I am missing. Is it just functionality of some walkers etc that require java 1.6 or are my processed bams not going to be complete eg not infact realigning pr recalibrating effectively under java 1.7? . No warnings arising or chromosome skipping etc. Or this this particular to the version GATK i am running. I was about to upgade gatk but want to get java right first.
Thank you for your help.

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi there,

    First, please note that you are running a very old version of the GATK. We are currently on version 2.2 and soon to move to 2.3. I would strongly recommend you upgrade, because the newer version of the tools give much better results.

    Second, as regards the Java version, the problem is that we haven't tested any version of the GATK with 1.7. We expect that problems will arise with it, but we're not sure at what level. At this point we can simply not guarantee that it will work properly, and can therefore not provide support for this configuration.

  • Thank you. In fact I have been running newer gatk which I downloaded earlier this year, my mistake...just put in folder for old version. Will test with new java 1.6 to confirm results are the same and then with 2.2. Thank you again.

  • Thank you. In fact I have been running newer gatk which I downloaded earlier this year, my mistake...just put in folder for old version. Will test with new java 1.6 to confirm results are the same and then with 2.2. Thank you again.

Sign In or Register to comment.