Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

GenotypeAndValidate doesn't work for SNPs

pdexheimerpdexheimer Member ✭✭✭✭
edited October 2012 in Ask the GATK team

When I run GenotypeAndValidate, all of the SNPs in my gold standard VCF get lumped into the "not confident" category. When I run UnifiedGenotyper over the same samples in DISCOVERY mode, these same SNPs have QUAL scores in the thousands.

I think the problem is in the creation of the UnifiedGenotyperEngines in GenotypeAndValidate.java (lines 335-340). The same UnifiedArgumentCollection is given to the constructors of both snpEngine and indelEngine, with the GLmodel field changed. But since each engine has a reference to the same structure, they both ultimately see the GLmodel that is set last (indel).

I'm sorry to not include a patch, I don't have local compilation set up right now.

Best Answer

Answers

Sign In or Register to comment.