The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

ReduceReads error: "Trying to clip before the start or after the end of a read"

loranialorania Member
edited September 2012 in Ask the GATK team

Hi,
I'm running GATK version 2.1-8 with reads mapped to mm10. ReduceReads fails somewhere on chr2 with above message. From previous posts I understood that this bug has appeared already? Could you please help me to fix it?
Thank you,

Ania

Tagged:

Comments

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    Hi Ania,

    That sounds like a different bug, but please try again with the latest version (2.1-9).

    If the bug still occurs: can you please check that your bam file is valid, and if so upload the segment of the file where the problem is occurring so we can test it?

  • Thank you so much Geraldine for your suggestion!
    I didn't validate my file at first - and as picard/previous steps of my GATK pipeline weren't complaining about anything, so I thought it is ok.
    It turned out that my .bam files still have some reads without mates (I thought that picard fixmates takes care of it). When I filtered them out, the file validates and ReduceReads works fine.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    I'm happy to help. You normally don't need to validate files at every step, but when you get an error like this, validation is a good first step to troubleshooting the problem.

Sign In or Register to comment.