We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

why do I get a missing-sample error with SomaticIndelDetector?

ignasiofignasiof Member
edited August 2012 in Ask the GATK team

I'm running the SomaticIndelDetector, and I get an error as if there was something wrong with the normal samples:

ERROR MESSAGE: BUG: we now require all samples in VCFheader to have genotype objects. Missing samples are 237,302

I would thank your help.

My whole command is as follows:

java -Xmx2g -jar ~/bin/GenomeAnalysisTK.jar \
-R ../../data/2011-11-08/ref.fa \
-T SomaticIndelDetector \
--out zindels017.200.vcf \
--verboseOutput zindels017.200.txt \
--window_size 200 \
--metrics_file zindels017.200.metrics \
--filter_expressions "T_COV<6||N_COV<12||T_INDEL_F<0.3||T_INDEL_CF<0.7" \
-I:tumor ../../data/2011-11-08/ma017.recalibrated.bam \
-I:normal ../../data/2011-11-08/ma097.recalibrated.bam \
-I:normal ../../data/2011-11-08/ma237.recalibrated.bam \
-I:normal ../../data/2011-11-08/ma302.recalibrated.bam

And I paste below the standard output and the standard error.

INFO 09:10:00,825 HelpFormatter - ---------------------------------------------------------------------------------
INFO 09:10:00,828 HelpFormatter - The Genome Analysis Toolkit (GATK) v2.0-39-gd091f72, Compiled 2012/08/10 15:55:35
INFO 09:10:00,828 HelpFormatter - Copyright (c) 2010 The Broad Institute
INFO 09:10:00,828 HelpFormatter - For support and documentation go to http://www.broadinstitute.org/gatk
INFO 09:10:00,829 HelpFormatter - Program Args: -R ../../data/2011-11-08/ref.fa -T SomaticIndelDetector --out zindels017.200.vcf --verboseOutput zindels017.200.txt --window_size 200 --metrics_file zindels017.200.metrics --filter_expressions T_COV<6||N_COV<12||T_INDEL_F<0.3||T_INDEL_CF<0.7 -I:normal ../../data/2011-11-08/ma097.recalibrated.bam -I:normal ../../data/2011-11-08/ma237.recalibrated.bam -I:normal ../../data/2011-11-08/ma302.recalibrated.bam -I:tumor ../../data/2011-11-08/ma017.recalibrated.bam
INFO 09:10:00,830 HelpFormatter - Date/Time: 2012/08/17 09:10:00
INFO 09:10:00,830 HelpFormatter - ---------------------------------------------------------------------------------
INFO 09:10:00,830 HelpFormatter - ---------------------------------------------------------------------------------
INFO 09:10:00,856 GenomeAnalysisEngine - Strictness is SILENT
INFO 09:10:01,774 SAMDataSource$SAMReaders - Initializing SAMRecords in serial
INFO 09:10:02,367 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.59
INFO 09:10:03,186 SomaticIndelDetector - No gene annotations available
INFO 09:10:05,150 TraversalEngine - [INITIALIZATION COMPLETE; TRAVERSAL STARTING]
INFO 09:10:05,150 TraversalEngine - Location processed.reads runtime per.1M.reads completed total.runtime remaining
INFO 09:10:08,654 GATKRunReport - Uploaded run statistics report to AWS S3

WARNING: BAM index file /N/dc/projects/DaphniaMA/results/2011-11-08/../../data/2011-11-08/ma302.recalibrated.bai is older than BAM /N/dc/projects/DaphniaMA/results/2011-11-08/../../data/2011-11-08/ma302.recalibrated.bam
WARNING: BAM index file /N/dc/projects/DaphniaMA/results/2011-11-08/../../data/2011-11-08/ma017.recalibrated.bai is older than BAM /N/dc/projects/DaphniaMA/results/2011-11-08/../../data/2011-11-08/ma017.recalibrated.bam

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

org.broadinstitute.sting.utils.exceptions.ReviewedStingException: BUG: we now require all samples in VCFheader to have genotype objects. Missing samples are 237,302
at org.broadinstitute.sting.utils.variantcontext.writer.VCFWriter.missingSampleError(VCFWriter.java:434)
at org.broadinstitute.sting.utils.variantcontext.writer.VCFWriter.addGenotypeData(VCFWriter.java:348)
at org.broadinstitute.sting.utils.variantcontext.writer.VCFWriter.add(VCFWriter.java:248)
at org.broadinstitute.sting.gatk.io.storage.VariantContextWriterStorage.add(VariantContextWriterStorage.java:156)
at org.broadinstitute.sting.gatk.io.stubs.VariantContextWriterStub.add(VariantContextWriterStub.java:232)
at org.broadinstitute.sting.gatk.walkers.indels.SomaticIndelDetector.printVCFLine(SomaticIndelDetector.java:1266)
at org.broadinstitute.sting.gatk.walkers.indels.SomaticIndelDetector.emit_somatic(SomaticIndelDetector.java:979)
at org.broadinstitute.sting.gatk.walkers.indels.SomaticIndelDetector.map(SomaticIndelDetector.java:580)
at org.broadinstitute.sting.gatk.walkers.indels.SomaticIndelDetector.map(SomaticIndelDetector.java:131)
at org.broadinstitute.sting.gatk.traversals.TraverseReads.traverse(TraverseReads.java:106)
at org.broadinstitute.sting.gatk.traversals.TraverseReads.traverse(TraverseReads.java:52)
at org.broadinstitute.sting.gatk.executive.LinearMicroScheduler.execute(LinearMicroScheduler.java:71)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute(GenomeAnalysisEngine.java:269)
at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(CommandLineExecutable.java:113)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:236)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:146)
at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:93)

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.0-39-gd091f72):
ERROR
ERROR Please visit the wiki to see if this is a known problem
ERROR If not, please post the error, with stack trace, to the GATK forum
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: BUG: we now require all samples in VCFheader to have genotype objects. Missing samples are 237,302
ERROR ------------------------------------------------------------------------------------------

Best Answer

Answers

  • TomAmesTomAmes Member

    I'm getting the same error, however only when I pass the bam file arguments as complete paths to other directories. If I call SomaticIndelDetector on two bam files in the same directory I'm running from, the tool works correctly.

    This is a bit of a problem, because I have all of my bam files in different directories. I'm hoping I won't have to link these (or worse, copy them) so that they live in the same place, just because gatk can't remember where the files were originally.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    This is strange because GATK is normally perfectly happy to use bams in different directories. That shouldn't matter at all. Have you used these "dispersed" bams successfully with other GATK tools?

  • TomAmesTomAmes Member

    Hi Geraldine,

    The UnifiedGenotyper tool works fine, either way.

    For the SomaticIndelDetector I get the same runtime error as above ('ERROR MESSAGE: BUG: we now require all samples in VCFheader to have genotype objects. Missing samples are ...') whenever I run the tool and the bam files/indices are in a different directory. This is true whether I use absolute or relative pathnames, whether the path is on the same or different volumes, and even if I place symbolic links to the files in the run directory.

    I'm currently installing the latest version of GATKlite to see if it is fixed. (The version I've been running is 2.1-13-g0f021e6).

    Thanks for your help!

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hmm, so the bug is specific to the somatic indel detector. Well, let me know if the problem persists with the latest version.

  • TomAmesTomAmes Member

    Will do, probably tomorrow. Thanks.

  • sahiilsethsahiilseth Member
    edited January 2013

    In my case the both files are in the same folder. Also I have cd'ed into the BAM files folder, but am still getting the same error

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie admin

    Hi @sahiilseth, can you tell me which version you're using, and what is your command line? It will be helpful if we can find out what you two have in common.

Sign In or Register to comment.