Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Java error when using ASEReadCounter

Hi, all!
I'm trying to do an allele-specific expression analysis on some of my samples and I gave ASEReadCounter a try. I'm having trouble with Java and I probably should post this on some java forum but thought you could help me since you would know better about GATK. Here is the error message I get:

 Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/spark/Partitioner
    at java.lang.Class.getDeclaredConstructors0(Native Method)
    at java.lang.Class.privateGetDeclaredConstructors(Class.java:2671)
    at java.lang.Class.getConstructors(Class.java:1651)
    at org.broadinstitute.hellbender.utils.ClassUtils.canMakeInstances(ClassUtils.java:30)
    at org.broadinstitute.hellbender.Main.extractCommandLineProgram(Main.java:318)
    at org.broadinstitute.hellbender.Main.setupConfigAndExtractProgram(Main.java:180)
    at org.broadinstitute.hellbender.Main.mainEntry(Main.java:202)
    at org.broadinstitute.hellbender.Main.main(Main.java:289)
Caused by: java.lang.ClassNotFoundException: org.apache.spark.Partitioner
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 8 more

At first I tried it using Java version 9. I thought this could be the problem, so I tried running it using Java 8 but that didn't solve it. Could you help me?

Sign In or Register to comment.