Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.
Attention:
We will be out of the office on November 11th and 13th 2019, due to the U.S. holiday(Veteran's day) and due to a team event(Nov 13th). We will return to monitoring the GATK forum on November 12th and 14th respectively. Thank you for your patience.

Form of .intervals

Hi!
I'm running GenomicsDBImport to combine my 100 samples and my command line is

gatk --java-options "-Xmx10240m -Djava.io.tmpdir=./" GenomicsDBImport --genomicsdb-workspace-path my_database -L 1.intervals --sample-name-map map2

The error message is
A USER ERROR has occurred: Badly formed genome unclippedLoc: Query interval "Contig:scaffold1 start:0 end:416820" is not valid for this input.

So I want to know what the intervals document should be like.

My reference only has thousands of sacffolds in it .
So the .intervals I used is
Contig:scaffold1 start:0 end:416820
Contig:scaffold2 start:0 end:868635
Contig:scaffold3 start:0 end:530760
Contig:scaffold4 start:0 end:723991
Contig:scaffold7 start:0 end:431581
Contig:scaffold8 start:0 end:94119
Contig:scaffold9 start:0 end:1039220
Contig:scaffold10 end:start:0 1039754
……

Is there anything wrong? How to correct it?

Thanks a lot!

Niu

Best Answer

Answers

Sign In or Register to comment.