We've moved!
This site is now read-only. You can find our new documentation site and support forum for posting questions here.
Be sure to read our welcome blog!

bamout option - mutect2: invalid argument value

noenoe Member
edited October 2018 in Ask the GATK team

Hi!
Kindly help me in fixing following error while trying to use bamout option with mutect2:

java -jar GenomeAnalysisTK.jar -T MuTect2 -R hg19.fa -I:tumor tum.bam -I:normal norm.bam -o output.vcf  --disableOptimizations --dontTrimActiveRegions --forceActive -L 17:61914938-61914948 -bamout chr17output.bam
##### ERROR ------------------------------------------------------------------------------------------
##### ERROR A USER ERROR has occurred (version 3.6-0-g89b7209): 
##### ERROR
##### ERROR This means that one or more arguments or inputs in your command are incorrect.
##### ERROR The error message below tells you what is the problem.
##### ERROR
##### ERROR If the problem is an invalid argument, please check the online documentation guide
##### ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
##### ERROR
##### ERROR Visit our website and forum for extensive documentation and answers to 
##### ERROR commonly asked questions https://www.broadinstitute.org/gatk
##### ERROR
##### ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
##### ERROR
##### ERROR MESSAGE: Invalid argument value '17:61914938-61914948' at position 14.
##### ERROR ------------------------------------------------------------------------------------------

If I try to use mutect2 without the options: "--dontTrimActiveRegions --forceActive -L 17:61914938-61914948 -bamout " it will work.
Why did this happen?

thank you in advance
best

Post edited by shlee on
Tagged:

Answers

  • shleeshlee CambridgeMember, Broadie ✭✭✭✭✭

    Hi @noe,

    It appears you are using GATK3 MuTect2. We recommend you upgrade to GATK4 Mutect2 as development work on GATK3 MuTect2 halted over a year ago. If you must use GATK3 MuTect2, be sure to use one of the final releases, e.g. v3.7, v.3.8.1. All of these options, --dontTrimActiveRegions --forceActive, should work. Tutorial#9183 outlines GATK3 MuTect2.

    Also, check that you do not intermix hyphens and dashes if you are copy-pasting commands. The best way to avoid introducing an unacceptable character is to type out the command.

Sign In or Register to comment.