Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

BaseRecalibrator stops working after 0.01 minutes; no error message

jreevejreeve Member
edited October 2018 in Ask the GATK team

I'm trying to run BQSR on a .bam file using an known set of SNPs I downloaded from Dyrad (https://datadryad.org/resource/doi:10.5061/dryad.2529hr1/2). I'm able to BaseRecalibrator working, but it stops immediately after initialising. I don't even have an empty output file. Any ideas where the problem might lie?

My Code:
./gatk BaseRecalibrator -R reference_genome.fa -I file1.bam --known-sites Stickleback_SNPs.vcf -O file1_recal.table

Output Log:
19:07:12.026 INFO NativeLibraryLoader - Loading libgkl_compression.so from jar:file:/data/programs/gatk-4.0.4.0/gatk-package-4.0.4.0-local.jar!/com/intel/gkl/native/libgkl_compression.so
19:07:12.135 INFO BaseRecalibrator - ------------------------------------------------------------
19:07:12.135 INFO BaseRecalibrator - The Genome Analysis Toolkit (GATK) v4.0.4.0
19:07:12.135 INFO BaseRecalibrator - For support and documentation go to https://software.broadinstitute.org/gatk/
19:07:12.136 INFO BaseRecalibrator - Executing as [email protected] on Linux v3.10.0-862.9.1.el7.x86_64 amd64
19:07:12.136 INFO BaseRecalibrator - Java runtime: OpenJDK 64-Bit Server VM v1.8.0_181-b13
19:07:12.136 INFO BaseRecalibrator - Start Date/Time: October 3, 2018 7:07:12 MDT PM
19:07:12.136 INFO BaseRecalibrator - ------------------------------------------------------------
19:07:12.136 INFO BaseRecalibrator - ------------------------------------------------------------
19:07:12.137 INFO BaseRecalibrator - HTSJDK Version: 2.14.3
19:07:12.137 INFO BaseRecalibrator - Picard Version: 2.18.2
19:07:12.137 INFO BaseRecalibrator - HTSJDK Defaults.COMPRESSION_LEVEL : 2
19:07:12.137 INFO BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_READ_FOR_SAMTOOLS : false
19:07:12.137 INFO BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_SAMTOOLS : true
19:07:12.137 INFO BaseRecalibrator - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_TRIBBLE : false
19:07:12.137 INFO BaseRecalibrator - Deflater: IntelDeflater
19:07:12.137 INFO BaseRecalibrator - Inflater: IntelInflater
19:07:12.137 INFO BaseRecalibrator - GCS max retries/reopens: 20
19:07:12.137 INFO BaseRecalibrator - Using google-cloud-java patch 6d11bef1c81f885c26b2b56c8616b7a705171e4f from https://github.com/droazen/google-cloud-java/tree/dr_all_nio_fixes
19:07:12.137 INFO BaseRecalibrator - Initializing engine
19:07:12.571 INFO FeatureManager - Using codec VCFCodec to read file file:///data/home/james/stickleback_LD/BQSR_SNPs_Fang2018.vcf
19:07:12.584 INFO BaseRecalibrator - Shutting down engine
[October 3, 2018 7:07:12 MDT PM] org.broadinstitute.hellbender.tools.walkers.bqsr.BaseRecalibrator done. Elapsed time: 0.01 minutes.
Runtime.totalMemory()=2105016320
java.lang.NullPointerException
at org.broadinstitute.hellbender.utils.SequenceDictionaryUtils.getContigNames(SequenceDictionaryUtils.java:463)
at org.broadinstitute.hellbender.utils.SequenceDictionaryUtils.getCommonContigsByName(SequenceDictionaryUtils.java:457)
at org.broadinstitute.hellbender.utils.SequenceDictionaryUtils.compareDictionaries(SequenceDictionaryUtils.java:234)
at org.broadinstitute.hellbender.utils.SequenceDictionaryUtils.validateDictionaries(SequenceDictionaryUtils.java:150)
at org.broadinstitute.hellbender.utils.SequenceDictionaryUtils.validateDictionaries(SequenceDictionaryUtils.java:98)
at org.broadinstitute.hellbender.engine.GATKTool.validateSequenceDictionaries(GATKTool.java:620)
at org.broadinstitute.hellbender.engine.GATKTool.onStartup(GATKTool.java:562)
at org.broadinstitute.hellbender.engine.ReadWalker.onStartup(ReadWalker.java:55)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.runTool(CommandLineProgram.java:132)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMainPostParseArgs(CommandLineProgram.java:179)
at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:198)
at org.broadinstitute.hellbender.Main.runCommandLineProgram(Main.java:160)
at org.broadinstitute.hellbender.Main.mainEntry(Main.java:203)
at org.broadinstitute.hellbender.Main.main(Main.java:289)

Best Answer

Answers

  • bhanuGandhambhanuGandham Cambridge MAMember, Administrator, Broadie, Moderator admin

    @jreeve

    Sorry about the delayed response as I was out sick.
    I need a little more information before resolving this issue. Have you been able to repeat this issue? Are you running this command on a NFS?

    Regards
    Bhanu

  • jreevejreeve Member

    @bhanuGandham

    This issue is repeating each time I run BaseRecalibrator and now the same thing is happening for HaplotypeCaller.

    I'm running this command on a lab server using a SSH from my local machine. If this is different to NFS please let me know.

    Cheers,
    James

  • jreevejreeve Member

    Hi @bhanuGandham,

    ValidateSamFile picked up the problem I was missing some read group information. I fixed it up with picard tools' AddOrReplaceReadGroups and it works now. Thanks for your help.

    Cheers,
    James

Sign In or Register to comment.