GATK4 MergeVcfs / ValidateVariants does not support ambiguous (IUPAC) variants (b37 reference)

FPBarthelFPBarthel HoustonMember ✭✭
edited July 2018 in Ask the GATK team

Perhaps this is intended, but GATK4 MergeVcfs / ValidateVariants do not support variants with ambiguous annotation, ie. 3:60830534-60830534 (M) in b37. ValidateVariants returns the following error when trying to validate a VCF file with such a base:

htsjdk.tribble.TribbleException: The provided VCF file is malformed at approximately line number n: unparsable vcf record with allele M

Best Answer

Answers

Sign In or Register to comment.