Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Filtering does not work due to missing MQ values

anapaulamachadoanapaulamachado LausanneMember
edited July 2018 in Ask the GATK team

Hello,

I'm trying to filter my VCF on MQ value. I've done it for other annotations using VariantFiltration with no problems, but MQ is just not collaborating.
So first I had it in an expression with the other filters, and realized that the filter on MQ was not working when checking the output as there were lots of call with values that should have been filtered.

Then I did it individually (--filterExpression "MQ<40.0") and it starts running fine until it collapses when it encounters a call with missing data for MQ. Error message:
Message: for input string "nan"

I've checked with grep and indeed there're some missing MQ values (why?) but it seems to me the tool should be able to ignore these...? I can't seem to find an option to tell it to ignore them - is there a way to do it?
I also tried with SelectVariants and got the exact same error.

I'd appreciate any help you can give me here !
Thanks,
Ana

PS - I'm on GATK 3.7

Best Answers

Answers

Sign In or Register to comment.