The current GATK version is 3.8-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Got a problem?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Download the latest Picard release at https://github.com/broadinstitute/picard/releases.
GATK version 4.beta.3 (i.e. the third beta release) is out. See the GATK4 beta page for download and details.

DataProcessingPipeline and --disable_indel_quals

edited July 2012 in Ask the GATK team

When I try to run the latest version of the DataProcessingPipeline I get the following error message:

ERROR MESSAGE: GATK Lite does not support all of the features of the full version: base insertion/deletion recalibration is not supported, please use the --disable_indel_quals argument

However in the recal case class this option is set to be true:
this.disable_indel_quals = true

Any idea how to solve this? It seams to me this is a bug, but I cannot find the source for the PrintReads class (guessing that its not in the public code), so I can't check it myself.

Regards,
Johan

Best Answer

Answers

  • CarneiroCarneiro Charlestown, MAMember

    Is this error happening in the PrintReads step of the pipeline? Can you paste this part of the output?

  • ebanksebanks Broad InstituteMember, Broadie, Dev

    It should only be possible to get this error during the BaseRecalibrator step. If you are seeing it during PrintReads then something is awry.

  • Ok. I found the problem. I was being a bit hasty last night (writing my last post just before leaving for the day). The error is thrown by the BaseRecalibrator step, just as ebanks wrote. However, the "this.disable_indel_quals = true" is only set in the PrintReads step. I tried removing it there and adding it to the BaseRecalibrator step, and now its working. This is what the code looks like now, with the removed line just commented away to make it more clear.

      case class cov (inBam: File, outRecalFile: File) extends BaseRecalibrator with CommandLineGATKArgs {
        this.knownSites ++= qscript.dbSNP
        this.covariate ++= Seq("ReadGroupCovariate", "QualityScoreCovariate", "CycleCovariate", "ContextCovariate")
        this.input_file :+= inBam
        this.out = outRecalFile
        if (!defaultPlatform.isEmpty) this.default_platform = defaultPlatform
        if (!qscript.intervalString.isEmpty) this.intervalsString ++= Seq(qscript.intervalString)
        else if (qscript.intervals != null) this.intervals :+= qscript.intervals
        this.scatterCount = nContigs
        this.analysisName = queueLogDir + outRecalFile + ".covariates"
        this.jobName = queueLogDir + outRecalFile + ".covariates"
        // Added this
        this.disable_indel_quals = true
      }
    
      case class recal (inBam: File, inRecalFile: File, outBam: File) extends PrintReads with CommandLineGATKArgs {
        this.input_file :+= inBam
        this.BQSR = inRecalFile
        // Removed this
        // this.disable_indel_quals = true
        this.baq = CalculationMode.CALCULATE_AS_NECESSARY
        this.out = outBam
        if (!qscript.intervalString.isEmpty) this.intervalsString ++= Seq(qscript.intervalString)
        else if (qscript.intervals != null) this.intervals :+= qscript.intervals
        this.scatterCount = nContigs
        this.isIntermediate = false
        this.analysisName = queueLogDir + outBam + ".recalibration"
        this.jobName = queueLogDir + outBam + ".recalibration"
      }
    
  • ebanksebanks Broad InstituteMember, Broadie, Dev
    Accepted Answer

    Thanks for reporting this. I've just pushed a patch into the stable version of the codebase.

  • Is it true that the --disable_indel_quals option is now removed from "BaseRecalibrator"? I am writing up my own pipeline using DPP scala (from a while ago) as a reference but I cannot find this option in the recalibrator. What does BaseRecalibrator now do to the indel quals? Thanks a lot!

  • I have removed this from my own pipelines, and it seems to be working fine. The Broad guys will have to confirm this, but my guess would be that the BaseRecalibrator now recalibrates base qualities for indels as well.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie

    That's correct, this issue only affected GATK Lite, so now that GATK Lite is gone, that option is no longer applicable. BaseRecalibrator does indeed recalibrate base qualities for indels in all versions form now on.

Sign In or Register to comment.